Dia sample project Digi ESP


I’m testing a Dia sample project from Digi ESP and I’m getting this error message in the terminal:

login: root
#> python dpdsrv.py

Launching Dia framework …

Dia auto-detect of rapid reb
Running in environment: digi
iDigi Device Integration App
lication Version
Source settings file: WEB/py
Destination settings file: W
Core: initial garbage collec
tion of 0 objects.
Core: Fatal exception caught
! Halting execution.
Traceback (most recent call
File "WEB/python/dpdsrv.py
", line 12, in ?
.path.abspath(‘.’), ‘dia.py’
File “WEB/python/dia.py”,
line 285, in ?
File “WEB/python/dia.py”,
line 280, in main
File “WEB/python/dia.py”,
line 68, in spin_forever
File “C:\Archivos de progr
_services.py”, line 417, in
File “C:\Archivos de progr
_services.py”, line 243, in
ceNotFound: “service ‘channe
l_manager’ not found.”

I’ve tested some other examples, and got the same result.

Any idea to fix it?.

Thanks in advance.


What is the firmware version of the gateway and xbee inside it?
Disable the Auto-Start settings and try again.
If you send the YML file and details about version of ESP it will be usefull.

Or submit an Online Support Request, Digi Experts can give you the best solution.


Hi 16ksa23

It is a connectport x8 gateway with firmware version 2.15.05 and python 2.4.3 interpreter. Its xbee module is a xbee pro series 2 with code ZB24-BUIT-004 revA1.

How can i disable de auto-start setting?? By going to the ip address of my gateway and using the webUI??
I went there and was there was an option similar to that that was disabled.
I read in this post something similar.


They enabled the auto-start setting to dia,py and it seemed it worked. I gave it a try and got a different error message:

Dia auto-detect of rapid
Error reading from Zipfi
le: WEB/python/dia.zip
Common cause for erroris
that the files inside t
he zip file were compile
d with the incorrect ver
sion of python.
Traceback (most recent c
all last):
File “WEB/python/dpdsr
v.py”, line 12, in ?
File “WEB/python/dia.p
y”, line 285, in ?
File “WEB/python/dia.p
y”, line 240, in main
from src.common.dia_
version import DIA_VERSI
IOError: zipimport: can
not open file WEB/python

I’m using ESP version 2.1.1.

I’ve also attached the yml file.




I made a few changes and it’s working now. I made a lot of stuff, so i will list them all. Perhaps all of them were neccesary.

  1. I updated the firmware of my gateway, POST first and then EOS.

  2. Changed the python.zip file in my gateway by going to my gateway ip address and using the webUI.

  3. In the first try, i deleted the dia.py, dpdsrv.py and dia.zip files that were loaded in a previous attempt and changed them by the same files located in my release folder inside the project folder in my PC.
    Then run it using cmd -> telnet -> “log in” -> #>python dia.py.
    That was the first time it worked. The project run successfully.

  4. I tried using the digi ESP after all those steps and worked normally as well.

As 16ksa23 suggested, I disabled the auto-start setting of my gateway. Otherwise, a wild error might appear.
Thanks 16ksa23.

Hope this is helpfull.

Do remember that you always must reboot after the project exits. So despite the fact that after the ‘crash’, the “#>” prompt shows up again, trying to run the code again will fail with very odd messages.

The ESP should normally detect if auto-start is turned on and ask you if it can be turned off (you MUST say yes).

If in doubt about the auto-run, you can also run the “who” command before manually running the python, and if any python threads are running, reboot.