Digi drivers broken on Redhat 7 for Digi RealPort Driver Package..

Built 40002086_W.src.rpm and installed it. on redhat 7.0

The init.d startup fails with

./rc.d/init.d/dgrp_daemon start

./rc.d/init.d/dgrp_daemon: line 24: [: =: unary operator expected

service dgrp_daemon start

/etc/init.d/dgrp_daemon: line 24: [: =: unary operator expected

Dump:init.d file:/etc/init.d/dgrp_daemon

Source networking configuration.

Suse 8.1 seems to make this a directory for some reason…

So we just won’t run this command on Suse 8.1

if [ ! -d /etc/sysconfig/network -a -f /etc/sysconfig/network ]
. /etc/sysconfig/network
# Check that networking is up.

[ ${NETWORKING} = “no” ] && exit 0 #<---- Line 24 that I commented out as $NETWORKING is null


The line 27 fails because there is no Networking env.

I commented it out but now it just dies. Will spend a few more minutes attempting to fix their software.

cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.0 (Maipo)

Anyone have a fix for their code. I have a older beta version but I would like an officially supported version to hand to our customers.

Digi does not offer free support for their drivers so there is NO way to ask them to fix their driver for the latest Redhat Enterprise release “Red Hat Enterprise Linux Server release 7.0 (Maipo)” .

It would seem after adding a

NETWORKING=yes to the top of the init.d script AND
manually created a /etc/dgrp.backing.store file that did not exist (added a config line from another box, changed IP to make the IP invalid). The digi drivers started…

Waiting on one of our developers to confirm the drivers are working as expected…


aa 16 auto default default default default never default


Comment out line #27 or add NETWORK=yes (ensure that you have network connectivity before starting digi in init.d digi startup script.

Add a /etc/dgrp.backing.store file

Seems to be working now…

Not aware of any driver issues with RH EL7. Would you be able to provide a typescript of the driver compilation/installation on this host?


rpmbuild --rebuild 40002086_W.src.rpm

Change to directory /root/rpmbuild/RPMS/(arch):

cd /root/rpmbuild/RPMS/(arch)

Where (arch) represents your system architecture (for example: i386, x86_64, etc…).

Use rpm to install the new driver package by typing:

rpm -ivv dgrp-1-9.35(arch).rpm

Configure the Digi Ethernet unit(s) and load the module by typing the following:

dgrp_cfg_node init (ttyid) (ip_address) (number_of_ports)

The following example configures a 16 port PortServer with device names of ttya00 through ttya15:

dgrp_cfg_node init a 16

Close the typescript:


Post the file called typescript residing in the directory where the script command was issued for futher analysis.

Digi does support their drivers and will waive any Technical Support fees if there is a bug found and validated.

I did try and I got this

Dear Valued Customer,

Digi International has implemented Support Agreements referred to as “Case Packs”. These agreements are necessary in order to obtain Technical Support assistance for many of our products, including the one you’re seeking assistance on.
These Case Packs were created to ensure our customers’ support needs were being met while maintaining effective Technical Support for our products.

Case Packs may be easily purchased from our on-line store at:
Free self-help is available on our web-site at http://www.digi.com/support, which provides information on commonly asked questions. This includes free driver, firmware, documentation downloads, as well as, knowledge base articles and peer to peer forums.
If you’ve already purchased a Case Pack at our on-line store, please provide your order number in order to proceed with this case.

Best Regards,

Technical Support Engineer

Digi International®
11001 Bren Road E
MN 55343

Direct: 952 912 3456
Main: 952-912-3444, option 6
Email: Tech.Support@digi.com
Online Support: http://mydigi.force.com/customers


Sorry dear Valued Digi Support, I don’t have time to assist with your software fixes. I would have when it happened as I tried to do. but that has passed now.


If you can provide the requested typescript, I can try to validate and issue a bug report.

I currently cannot replicate this on my EL7 host (kernel: 3.10.0-123.6.3.el7.x86_64).

I was able to see the “line 24: [: =: unary operator expected” message, however it did not prevent the driver daemon from starting (i.e. non-destructive error):

/etc/init.d/dgrp_daemon restart

/etc/init.d/dgrp_daemon: line 24: [: =: unary operator expected
/etc/init.d/dgrp_daemon: line 24: [: =: unary operator expected
Stopping DGRP daemons:
Daemon for id “a” ( stopped.
/etc/init.d/dgrp_daemon: line 24: [: =: unary operator expected
Starting DGRP daemons:
Daemon for id “a” ( started.

I have submitted a bug report.

Attached is a copy of the install Log as requested… As you can see there is an error on Red Hat 7 using the 40002086_W.src.rpm install base. If that is not the right base, that could be. But since there was no Red Hat 7.0 7.1 7.2 in the pull down just “Linux” that is the one I downloaded…


Here is the URL with the Text in it for the install.


After a reboot the digi drivers FAILED to start…

(hence the problem is not minor.)

[root@bag2 init.d]# ps -ef | grep -i dg
root 12964 12919 0 10:05 pts/0 00:00:00 grep --color=auto -i dg
[root@bag2 init.d]# service dgrp_daemon status
/etc/init.d/dgrp_daemon: line 24: [: =: unary operator expected
[root@bag2 init.d]# ps -ef | grep -i dgrp
root 12976 12919 0 10:05 pts/0 00:00:00 grep --color=auto -i dgrp
[root@bag2 init.d]#

Added to this post…

Attempting to start it manually:

[root@bag2 init.d]# service dgrp_daemon start
/etc/init.d/dgrp_daemon: line 24: [: =: unary operator expected
[root@bag2 init.d]# ps -ef | grep -i dgrp
root 13013 12919 0 10:09 pts/0 00:00:00 grep --color=auto -i dgrp
[root@bag2 init.d]#

I’m not able to replicate this using the same kernel version and driver. Can you show the contents of /etc/dgrp.baking.store? Also, can you provide the results of “ps -ef | grep drpd”?

Any thoughts on how I might be able to replicate this?

There is a beta driver build to address this located at:


Worked with Digi on this, This worked great on Red Hat 7.1 . Thanks for your efforts… Tested from source files. AOK!