Digiboard pc/8i, SCO Xenix on a P2-450

I am getting error messages when trying to install the pc/8i digiboard under SCO Xenix 2.3.4 ( which was the last version ). It does not seem to matter which memory address I use or which I/O port I choose. I either get an “no memory at xxxxx address for the digiboard” or and “I/O error at port xxx”. I have tried many combinations of address and I/O ports with no success.

The odd thing is that the digiboard and the Xenix software works perfect on a 486/66 and a 486/50 computer.

I have flashed the motherboard’s BIOS to the lastest version, and have tried the last digiboard driver software v 5.3.0. Still no luck.

I have tried to install on 2 different Pentinum machines and both get either address errors or i/o errors.

I am beginning the think that the digiboard may not work on a Pentinum machine.

Any thoughts suggestions or questions would be appreciated.

Thanks in advance.


You will need to look in the BIOS for some kind of toggle that will reserve the memory range you wish to use for the adapter. (IE: d000 is the most common) In best case scenarios it might say something like “Memory Reserved for ISA device” It might be generically labeled as “Memory window starting address” and “Window Size”. BIOS writers can be cryptic, so look for something indicating that the memory in question is not being managed by the PCI Controller. (Memory exception, Memory window, Memory reservation ect…)



The only thing I had in the BIOS was “Memory Hole at 15m-16m”. It was disabled. I enabled it. Reinstalled software at E80000h and I/O port at 320h.

I now get an i/o error at port 320. Disabled the memory hole option and still get the i/o error at 320.

In your reply, you said that "D000 is the most common memory range. The only memory range in my book with a D prefix is D0000h (with 4 zeros) and D00000h (with 5 zeros). The D0000h is below the 1 megabyte range. And the D00000h is at 13.6meg range. I thought the board would need to be installed. ABOVE the 15m range, where the memory hole is. That is why I tried the E80000h address.

Also do you know which is checked / tested first. The i/o port or the memory address when Xenix loads? If I know which is checked first, then my process of elimination I could find an i/o and memory address that would work.

Thanks for trying.

Your problem is that this card is not supported in anything above a 486. You can only address this card below 1 meg and it must be an open 64k window. But again, this card is not supported above a 486 processor.

Message was edited by: ronk


Finally got the card to work.

Used D0000h memory address,
320h i/o port,
Enabled memory hole at 15-16meg, in the BIOS
And had to jumper the digiboard to 64k ( it is a 128k card )
Card passes all the digi tests and Xenix now boots fine.

It will be interesting to see how stable this will be since the board is NOT supported on anything above a 486.

I appreciate all the help with this.