Digital Input edge detect not working

I have two Xbee Pro S2B radios and I’m having some trouble.

I can send remote AT commands to set digital pins high and low from the coordinator to the end device. However I can’t set a pin as a digital input or get edge detection working. The destination address in the end device is the address of the coordinator. I have tried configuring all these settings in the X-CTU program and still no avail. What could I be doing wrong?

When I configure the settings in X-CTU as D1(3-digital input) and the Edge detect as 0x0002 (mask for D1) it made no difference, it isn’t sending any packets to the other device.

My switch I have connected to D1 is normally open and when you depress it, it connects to ground. Pull-up Resistor Enable is set to 0x1FFF so I figured this would be the correct way to connect a switch. I tried just taking a lead from that pin and touching ground and Vcc(3.3V) but I still am not getting any packets to be sent.

Is there something I missed?

What firmware are you running? Is the XBee with IC set runnign as router or end-device? If End-device, then the SN/SP of the other Xbee must be correct to allow the end-device to remain a ‘child’ long enough for the IC to occur.

You may need to use IR also to ‘refresh’ the parent’s understanding that the child/end-device still exists. Else when the child/end-devcie sends the IC sample the parent rejects it.