disabling sniffer chattiness

How do I turn off the sniffer chattiness? These are the messages like:

Entering server port, type ^Z for port menu
or
New sniffer session started.
or

‘noboby’ initiated a new sniffer session.
or

Main session has been finished.

These messages show up in the datastream and corrupt it:

$ nc 192.168.11.165 20000 |hexdump-esr
0000 20 45 6e 74 65 72 69 6e 67 20 73 65 72 76 65 72 Enterin g server
0010 20 70 6f 72 74 2c 20 2e 2e 2e 2e 2e 20 74 79 70 port, . … typ
0020 65 20 5e 7a 20 66 6f 72 20 70 6f 72 74 20 6d 65 e ^z for port me
0030 6e 75 2e 0d 0a 0d 0a 20 4e 65 77 20 73 6e 69 66 nu… New snif
0040 66 20 73 65 73 73 69 6f 6e 20 73 74 61 72 74 65 f sessio n starte
0050 64 20 2e 2e 2e 0d 0a 0d 0a 0d 0a 20 4d 61 69 6e d … … Main
0060 20 73 65 73 73 69 6f 6e 20 68 61 73 20 62 65 65 session has bee
0070 6e 20 66 69 6e 69 73 68 65 64 2e 2e 2e 20 0d 0a n finish ed… …

All I want any of the sessions to see is the raw data.

Incidentally, how do I keep all the sessions from terminating if the first connection terminates?

thanks

You can get rid of the “Entering server port, type ^Z for the port menu” by disabling the global escape menu under host mode configuration for the serial ports.

Disabling the login prompt can be done by setting “Login authentication” to None.

You may also want to consider using port logging instead of “sniff”.