Im trying to use the ditty command:

ditty -n ttyn1a cspeed ttyn1a

ditty -n ttyn1a fastbaud ttyn1a

But it says: ditty: invalid option – n

What am I doing wrong?

FAQ: Red hat 9 and Digi Neo 1 port

This might be occurring because you list the device name twice, I’m not sure. Try dropping the device name not after the -n and see if you still get an error. You could also try doing the command without the -n switch altogether, but you’d still need to drop one of the device names.

Even though the cspeed flag does not show in the ditty results, the command will work:

ditty.dgnc cspeed 76800 ttyn1a

The -n flag will not work with this syntax.

Once the cspeed command is issued, you can confirm the baud setting is implemented:

ditty.dgnc -a ttyn1a


ditty.dgnc -n ttyn1a