Downgrade Firmware on the AnywhereUSB/5 (G1) ?

I have several AnywhereUSB/5 G1 units that were working fine until I recently I upgraded the Anywhere USB Driver / Application. Now I cannot connect to the attached USB device. I have to assume this is because it also upgraded the firmware on the AUSB/5 G1 units and that has caused a problem with my attached USB device.

With that said, I have the same USB devices attached to AUSB/2 G2 units and they work fine with the latest firmware upgrade (82002116_E.dwn). However, the USB devices did not work with the previous firmware revision that I had running on those units (82002116_b1.dwn). Once I upgraded the AnywhereUSB/2 G2 units up to the latest (82002116_E.dwn), they started working.

Obviously, something in the firmware is causing an issue so I would like to try downgrading the firmware on the AnywhereUSB/5 G1 units.

It appears the firmware for the AUSB/5 G1 units is contained in the four files labeled FWAWxxxxxxx.bin. Where can I get older versions of these files?

I tried installing older driver / application files from the FTP site but they all seem to contain the latest firmware files.


Can this be done? If so, please let me know how.

Thank You,

Hi AJ,

Thanks for the detailed info.

The firmware on the legacy (“G1”) AnywhereUSB/5 is updated automatically, and the version depends on the version of the AnywhereUSB software that you’re running at the time you connect to the AnywhereUSB.

So basically, if you’re looking to put older firmware on a legacy AWUSB/5, you’ll need to install older AWUSB software and then connect to the unit. You can confirm that the firmware is being updated by looking at the Port LEDs on the front panel of the unit, right after you click the Connect button. If those LEDs are flashing rapidly amber(or red-ish)/green then the firmware is updating.

Which version of the software do you need to use? It depends on which firmware you’re looking to revert back to. Do you know? Or do you know which version of the software you were running before you updated it?

Hi Jeremy,

Thanks for the quick response.

I did try installing an older version of the software but the firmware seemed to always reflect the same version.

I don’t recall the version I was using before the most recent upgrade. It was probably the same version that came on the CD that we got with the unit years ago. I believe they have “40002670_A” through “G” on the FTP site. I want to say I was using revision “B” before the upgrade to “G” but I’m not positive.

I will give it another try and I will let you know what happens.


I tried this again and I got the same results. No matter which AWUSB software revision I run, the firmware remains the same on the AWUSB/5 G1 units.

It seems that the older revisions of the AWUSB software, all the way back to revision “A”, reflect a firmware version of 2.30.5 or 2.30.005 (which appears to be the same thing).

No matter which revision I install, when I click on VIEW > DRIVER INFORMATION, it always indicates a version of 2.30.5 or 2.30.005 even though the BIN files have differing names among the different revisions.

For Example:
Rev A FWAW250010x.bin
Rev B FWAW251010x.bin
Rev C FWAW270010x.bin

Rev G FWAW310010x.bin

It seems like all of the revisions A to G contain the same firmware version. Is this really the case or am I doing something wrong?

How can I accomplish a downgrade?


The firmware hasn’t been updated on the legacy AWUSB/5 in a while, so what you’re seeing isn’t surprising. I did a little research and it looks like that Rev A you mentioned is our v2.50 driver which was released on 9/11/08.

Earlier versions (v2.40 and before) may have older firmware, so that’s what you should try next. That’s really the only thing that you can do. There’s no workaround. Even if there was, you’d probably run into issues if you tried to use firmware and drivers that weren’t compatible, since certain versions are designed to work together.

Links to older driver versions are below. Note that the older they get, the less compatible they are with newer Operating Systems. I’d use Windows 2000 or Windows XP to ensure that the OS is supported.



1.46 rc2: