error with instruction import zigbee

Hi all,

I have downloaded dia 1.1.17 and imported it in Pydev, but it seems there are errors (72 !). The main error is on the following instruction (in " for exemple):

import zigbee

Do you know why “Zigbee” can’t be import ?
Do think a file is missing in the dia i have downloaded ?

Best regards.

Hi Cedric,

You need to have a file called ‘’ in the python directory on your device. Whenever you see that ‘import zigbee’ the script is requiring that library to be present.

In future releases of the Dia, that requirement is eliminated, but that’s the future, so we have to make due today.

I’ve attached the file, please upload it using the HTTP form found here: (Adjust for your IP)


First thank you for your help.
I have insrted your file “” in my python project, in the folder “scr/devices/xbee/xbee_devices”, but there is still error with the instruction “import zigbee”. I have tried to move the file in others folders, but it doesn’t work.
In the file “” these vaiables generate the error “undefines variable”:

  • ZBS_PROT_802154
    and theses variables are not defined in “” you attached. So, I don’t know where to fond the definition of these variables

These instructions generate error too (“Unresolved import”):

  • “import yaml” in “” file
  • “import termios” in “”
  • “import digi_cmd as cmd” in “”
  • “from digicli import digicli” in “”
  • and many others…

Is it normal ?


Hi Cedric,

iDigi Dia is a framework which is supposed to work under a Digi ConnectPort device. You can try to import it in Pydev (really you don’t need to do it), but as you have said it will give some errors. It is because the Digi ConnectPort devices own (or have embedded) some of the modules that Dia is asking for. For example the digihw, digicli, digi_cmd… The reason you are still receiving the Zigbee import errors is because the module imports all the members from the one, which is also included inside the Digi CP device, not in the Dia structure.

So, if you want to build a Dia project you don’t need to import the Dia structure in PyDev, just use the “” script (contained in the Dia structure) with your configured “yml” file to build your own Dia project. It will compile all the necessary modules into a zip file that must be transferred to the CP device with the “” file. Once transferred, restart your CP and execute the “” script (python “”) to initialize the Dia framework into your remote device.

You can find the complete guide on how to create Dia projects under the following link:


Thank you Diego,

Indeed, Dia is not compatible with Pydev Environnent, that’s why it generates errors (it misses module). I have tried to build my dia project, and that works.

Best regards.