Error writing AT parameter > Port configuration not valid

I tried maxing out the baud rate of my two xbees and I am getting this error. I see that there is another post about this here. I have the exact same issue as this person, but I cannot download the legacy tool because I am on an M2 mac. Is there another way to fix my radios easily such as a factory reset?

What is the exact part number you are working with?

What is the baud rate you are trying to set it to?

I am using the XBee 3 Module and tried setting it to the maximum possible baud which I believe was 921600. I should have stuck with 115200…

I was somehow able to connect to it on my windows at home and change the baud rate from there. Not sure if there is an issue with the MAC application but I’m glad it works again :slight_smile: I was also not able to install the legacy version of x-ctu and this was because I didn’t have the right runtime installed so not sure what runtime it needed.

I am glad to hear you got the issue resolved. I do not know what version of Runtime is needed on the MAC. So I can’t answer that.

The legacy version of XCTU is really for the products before the XBee 3.