FTP server on RCM4300 refuses new connections after several consecutive wrong user/passwords logins


That’s my problem. Using a RCM4300 module and the sample code:


I can log in with no problems when introducing a right user/password. But, if I make a user/password mistake several times, the FTP server on the RCM4300 refuses new connections and the only way to reset this is restarting the module.

I have used several FTP clients on the PC: FileZilla, WinSCP, CoreFTP. Always the same result.

I have also tested this problem with other RCM4300 modules to avoid any problem regarding the ethernet chip. The same problem!

I do not know what to do, because I consider that this is a very important problem . This FTP server does not work at all, is useless if it blocks when you fail writting the user.

Any suggestion or idea?

Hello, Did you inform this issue to digi tech support? If not send mail to Tech.Support@digi.com , the tech support will help you. It seems like it is very important issue.

I have RCM4300 board, I will try to check this issue. can you send your application please?

Did you make any changes in the default updpages.c application?

yes I contacted tech support. But they told me that they hadn’t that problem.

I’ve tried both dynamic C 10.70 & 10.72 getting the same problem.
Sorry, I can’t send the application, but my problem also occurs executing the sample code \FileSystem\FAT\updpages.c with no changes.
Things that I have tried:
-Using the default IP address or changing it to other like
-I tried to connect the PC to the RCM4300 with a crossover ethernet cable and I also tried to connect the RCM4300 to a local network, with no good results.

-I have used several FTP clients:
FileZilla –> I get connection refuse message when entering wrong user/pass and no more connections any more.
WinSCP –> It is better than FileZilla but at the end I can provoke the connection refuse.
TotalCommander –> It seems to work fine. But the problem is that a FTP server shouldn’t get blocked with some FTP clients.
-I have tried to compile with other computers–> no solved

I would appreciated if you could try this on your RCM4300:
-Compiler: Dynamic C10.72. Compiler options: optimize for size, separated code and data. I have no added anything to the compiler, no updates or something like this, just the “original dynamic C 10.72”
-Program: sample code updpages.c with no changes
-I execute the program keeping the programming cable connected to the RCM4300 and then I use the FileZilla 3.5.3 to test.
-I enter a right user/pass to check and then I enter several time a wrong user name. Normally in two tries I get ECONNRefuse from FileZilla , but sometimes it takes more tries.

And other tests I did:
-I tried the same program on a RCM3910 and in that case, all ok! (what’s the difference??)

Ok, I will check on my board and let you know the results.

Hello, I had checked this issue on my RCM4300 , yes ,FTP server on RCM4300 refuses new connections after several consecutive wrong user/passwords logins. However , I will check with digi and let you know , if they provide any work around.


thanks a lot for testing it on your RCM. Please, if you get a work around let me know. If I get the solution, I will explain it too.


I’ve contacted Digi support but I didn’t get a work around. The last thing I know from them is that they were going to try to reproduce this issue. Nothing since that day.
Have you tried something more or you have a solution?

Hello, When I checked this issue long back on RCM4300, I could able to reproduce this issue, But today I checked on my RCM4300 module, Could not able to reproduce this issue. Always it is working fine, I have given the wrong username around 30 times then, when I given correct username at 41 time, it was login succesfully , It did not show any error.

I have checked this issue several times, It did not give any error now.
Still I am trying to reproduce this issue.


now your rcm4300 working well. Have you done something different in comparison to the first time? (programming in flash, executing in ram. separated data & code, other sample code,…)

Hi , I did not do any modifications, but unfortunately I lost the working application because of some memory issue, today again I checked, I could able to reproduce this issue :frowning:


we are working with a RCM6700 module (based on the Rabbit 6000 processor), with a SD card attached and a FTP server, that publicates the SD content, for a remote harvest of seismic data.
The FTP server has two accounts: anomynous and admin, but at the present both are read only; this is, just can view the SD contents and download the files.

But, we have more or less the same problem with the FTP.
Let me explain, but be patient since english is not my native language:

  • We can log without problems on both accounts, from the Firefox and DOS (starting a command window and typiyng FTP, etc. etc).
  • But if we use Filezilla or Win SCP, when we try to download a file, the connection freezes, and the only way to restore it, is resetting the Rabbit…

We added explicit time out macros to the FTP server, on data and command ports, but the Rabbit never execute it, and keeps waiting something forever.
We added the macro to have two simultaneous connections, and when the Filezilla hangs one of them, the other (with Firefox or DOS based ftp client), remains working fine, but the first one never recovers until we do a Rabbit reset. It is unnaceptable!!!

Please give me a clue about how can we make it work.
I can send the code we are working on; the very basic skeleton can be the FTP example on the Vol 2 of TCP/IP Rabbit book, on page 374. This example has not SD card, but has the same behavior I am describing.

Thanks in advance,