Got error while programming my RCM6750

Hi there, I got an error message while trying to program my firmware into the RCM6750. The error message is below:

“In Project Options’ Define Box, define MAX FIRMWARE BINSIZE to be substantially less than the serial boot flash size. To make roughly half of the serial boot flash available for mass storage, put MAX FIRMWARE BINSIZE=0x80000 into the Project Options’ Defines box.”

I’m using Dynamic C 10.66. The weird thing is that, out of 25 pcs of RCM6750 I program with the same firmware, 5 pcs will encounter this problem. The other’s programmed successfully. Why is it there is this problem? Is it somehting wrong with the rabbit chip internally?

Hello, Please check,are there any board version changes on the module(working and non working modules)?

Try to run RCM67XX sample applications (C:\DCRABBIT_10.72\Samples\RCM6700)on the module with Digi’s RCM67XX dev board by using Dynamic C 10.72 (with latest patches).

Still if you are getting the error, might be problem with the modules. In this case , contact digi technical support.


I have tried using the Dynamic C 10.72 to program my firmware onto the 5 pcs of RCM6750 but still same problem. I added this line: MAX_FIRMWARE_BINSIZE=0x80000 onto the define section in the project option then only it can successfully programmed.
What does this means? Why is it some RCM6750 no need to add this line (20 pcs) but some need (5 pcs)?

Hi there… I have checked the version number for the 5 pcs of rCM6750 which have the problem. It is 30010422-03 REV B. But it is the same as the other 20 pcs which does not have this problem. Do you know why this is happening?

I have try program a sample firmware to the 5 problem pcs and it can run. But I don’t think it’s my firmware problem because 20 pcs can be programmed.

Hello, There is a latest serial flash patches at digi website, try to run application with these patches and check the issue. You can find the patches at the below link.

I have tried the patch but still same problem occurred. Is there anything I can do?

Are there any differences in the processor and memory devices on the modules? I.e. all the same device types/revs/speed grades etc.

Yes. All my RCM6750 has 30010422-03 REV B as version number on the back of the module. Is it something faulty with the flash inside?

If you run Samples/RCM6700/Serial_Flash/sflash_inspect.c, does it report the same information for both types of boards? Try defining SFLASH_VERBOSE in the Project Options/Defines tab before compiling for detailed information.

Does Dynamic C identify them both as RCM6750? Is it possible you received some RCM6700 boards by mistake?

I have tried to run the sflash_inspect.c.
For the 5 pcs problematic RCM6750, it will still show the same error message.
As for the other 20pcs of RCM6750, it programmed successfully.

I don’t think it is RCM6700, because physically, we can see an extra flash chip on the back of the module.

If you define MAX_FIRMWARE_BINSIZE=0x80000 can you run that program? You might also want to try running Samples/UserBlock/idblock_report.c and looking for differences. Those 5 modules are different in some way, and it would be useful to figure out exactly how.