Help using XBee IO lines - Explorer Regulated Board

I have a setup that consists of one Xbee S2C connected to rx3/tx3 of an Arduino Mega set up as the coordinator and another XBee connected to an Explorer Regulated Board. I have set up my end device such as to read a potentiometer from DIO3. In my XCTU configuration, I set up DIO3 as ADC [2] and I have a sample rate of 1000ms.

I know my XBees are connected to each other because of the LEDs on the boards, and I know that the cordinator (attached to Arduino) is receiving something every 1000ms (from the blinking) so the configuration is correct. I even tried something along the lines of this ( and it worked.

Now, the end device (potentiometer XBee) is attached to the breadboard with 5V and GND attached to the appropriate pins and a potentiometer is attached to DIO3. This XBee does not blink at all (other that PWR) so that makes me think that the problem is with this XBee. I am inputting 5V and GND into the potentiometer (per usual) and I am not using VREF at all (I think this XBee has hardware for that and the board has no VREF pin).

What could be the problem? Should I not input 5V to the potentiometer although the board takes care of regulating power to 3.3V?

You should not be connecting the potentiometer to 5V. It needs to be either 3.3V or 1.2V depending on the XBee.