Here another "No Processor found" issue


Before posting I read a lot of message in this forum and in others.
I run Dynamic C 10.11 with a RCM4100. Today, I have programmed several times the module on my own board composed of a 3V3 power supply, a LED connected to PE1 and nothing else. The /reset in is unconnected as it is tied-up by R27 on the module itself.

I wrote a simple program to flash the led and it works fine. After several programming cycle I can’t connect to the processor anymore. The IDE returns error while is sending Cold Loader. :frowning:

If I remove the programming cable the led flashes as expected, so the module is running. Furthermore:

  • both primary and RTC clock are running
  • power supply is present
  • checked the PROG connector rather DIAG
  • checked the right COM port on laptop
  • turned off, turned on after 1h: same error

If I move the module from my board to the Rabbit DevBoard I can program it. Thus, I guess there is a problem with my board… But why I was able to program before? :confused:

What should I check?

Marco / iw2nzm

I was wondering if you figured out what your issue was with your rabbit. I am having the same problem.

Yes :cool:

The I/O lines were connected to a pin header for test purpose. Please note that nothing was connected to the header. The wires length was about 1,5 inch.

Well, I had to break wires that were the same of programming lines. Then it worked again.

Marco / iw2nzm

hi this is swamy from India.i am working on RCM 3000 . it"s my own design .Based on RCM3100 core module. here i am getting one prob .
1.I am unable to programme the RCM3000 after few programing cycles . it is showing the error “while sending pilot bios target communication error” pls help me to come out of this prob .
a) one thing i have observed that same unit work for some times in that time the cs1 pin of the
RCM3000 is low. CS1(chip select of the RAM).
b)And same pin will be high when it is unable to programme.

pls my i know on which condition the cs1 pin will be high.

The error I get is No Rabbit Detected while cold loading. I have put the programming cable every which way on the rabbit but to no avail.