How to configure i.MX51 for android which has already installed Windows CE?

I am trying to port android to i.MX51. It has already installed Windows CE. I am not able to connect to PC using serial port. Let me know how to boot the board in U Boot mode to be able to communicate with PC over serial. Thanks.



you mean that you want to use andorid OS replace the win CE OS? but you serial port connect to PC ,the serial port no ouput? maybe you will check the module or the kit is working or not.

Try baudrates 38400 & 115200 while connecting to serial port and then turn on module on digi dev board.
Or is this module placed on custom board?

If module is booting you could see few leds glowing near power switch. and if there is data transmission in serial port Txd, Rxd lines will be blinking.

Few related knowledge base articles:

Yes, you are right. I want to replace it for Android. I am not sure about the procedure.

If you are using the MX51 development board, Also check BOOT CON switches S8 and S9, all should be off position, then only the module boot from the flash. If the switch S8.1 is on, the module try to boot form the Micro SD card.

I am able to see some junk characters on serial console. I tried using 38400 as well as 115000 BR. I am not able to see any valid character after pressing the ? key.

there is a document which edit by me, it will tell you how to install andorid OS, pls download from: you need a software Digi TFTP Server. if you module is working, you will install andorid OS successfully.

Hello, May I know what are the LEDs glowing on the dev board once the board power on?What are the serial port settings you have?

I am able to communicate on UART2. Able to send command and receive response. LEDS are blinking. Now I want to download the boot files. I have connected the ethernet cable to PC and board from my modem. I can see the ipaddresses and same subnet mask. It looks like some setting in fftp server is issue. I have copied all the three files to C:tftproot folder and also copied tftp exe into the same folder. I run tftp from there after setting the tftp exported server pointing to c: ftproot
. When after setting all the ipaddr , serverip and netmask, i give the uboot ftfp command. here it fails.

Hello,May I know,why do you want to update the U-Boot file?
If you do not upload proper U-Boot image on to the module the module will not boot.So pls take care while uploading the U-boot image.

I suggest that , please contact Digi technical support, they ,may provide you step by step guidance on this.

Thanks, I will contact tech support.