How to debug a WR21 failing to send SMS's?

For some reason none of our WR21 manages to send SMS’s. My first gues was a issue with our provider but putting the sim in a regular smartphone allowed it to send SMS.
The WR21 can receive SMS (seen in event log) but can’t reply. Any way of knowing more about the issue then ‘SMS failed to send’? (which is shown in the eventlog).

Trying to send an sms with the sendsms command doesn’t work either.

Which actual WR21 do you have?
A WR21-L2 or WR21-L3 do not support SMS.

If you have something else then post your “config c show” removing your personal data.

Does this answer your question? WR21-L41A-DE1-TA
I managed to send one sms with the device (tried > 30 times)

What firmware are you running? If it is anything less than 5246 then you will have problems. There is a known bug listed in the release notes that is fixed with this version. (SAROS-255) in

Remembered i’ve copypasted the debug.txt to my desktop earlier…

Digi TransPort WR21-L41A-DE1-XX Ser#:350556 HW Revision: 1203b
Software Build Ver5246. Aug 15 2014 12:20:23 WW
ARM Bios Ver 7.21u v43 454MHz

So the firmware is indeed the latest.

So can you post your full config c show here with out the personal info?

Also what is “ppp 1 ndis ?” set to?

‘config c show’

addp 0 enable ON
lapb 0 ans OFF
lapb 0 tinact 120
lapb 1 tinact 120
lapb 3 dtemode 0
lapb 4 dtemode 0
lapb 5 dtemode 0
lapb 6 dtemode 0
ip 0 cidr ON
def_route 0 ll_ent “ppp”
def_route 0 ll_add 1
def_route 1 ll_ent “ppp”
def_route 1 ll_add 2
dhcp 0 IPmin “”
dhcp 0 respdelms 500
dhcp 0 mask “”
dhcp 0 gateway “”
dhcp 0 DNS “”
sntp 0 server “
ppp 0 timeout 300
ppp 1 name “W-WAN”
ppp 1 phonenum “983#”
ppp 1 IPaddr “”
ppp 1 timeout 0
ppp 1 firewall ON
ppp 1 use_modem 1
ppp 1 gprs_sim 1
ppp 1 cdma_backoff ON
ppp 1 aodion 1
ppp 1 autoassert 1
ppp 1 pwr_dly 40
ppp 1 pingip “”
ppp 1 pingint 30
ppp 1 acttries 30
ppp 1 pdacttries 10
ppp 1 inhibitno “2”
ppp 1 r_chap OFF
ppp 2 name “W-WAN”
ppp 2 phonenum “983#”
ppp 2 r_addr OFF
ppp 2 IPaddr “”
ppp 2 l_addr ON
ppp 2 timeout 0
ppp 2 firewall ON
ppp 2 use_modem 1
ppp 2 gprs_sim 2
ppp 2 cdma_backoff ON
ppp 2 aodion 1
ppp 2 autoassert 1
ppp 2 pwr_dly 40
ppp 2 pingip “”
ppp 2 pingint 30
ppp 2 acttries 30
ppp 2 pdacttries 10
ppp 2 inhibitno “1”
ppp 2 l_pap OFF
ppp 2 r_pap ON
ppp 2 l_chap OFF
ppp 3 defpak 16
ppp 4 defpak 16
web 0 prelogin_info ON
modemcc 0 info_asy_add 4
modemcc 0 apn “"
modemcc 0 buapn "
modemcc 0 usebuapn ON
modemcc 0 retry_apntim 10
modemcc 0 stat_retries 30
modemcc 0 sms_interval 1
modemcc 0 sms_callerid "

modemcc 0 sms_concat 10
modemcc 0 apn_2 “none”
modemcc 0 stat_retries_2 30
modemcc 0 sms_interval_2 1
modemcc 0 sms_access_2 1
ana 0 l1on ON
ana 0 lapdon 0
ana 0 asyon 1
ana 0 logsize 45
cmd 0 autocmd "tcpperm ASY 0 443 -l443 "
cmd 0 unitid “ss%s>”
cmd 0 cmdnua “99”
cmd 0 hostname “digi.router”
cmd 0 asyled_mode 2
cmd 0 tremto 1200
cmd 0 rcihttp ON
user 0 access 0
user 1 access 0
user 2 access 0
user 3 access 0
user 4 access 0
user 5 access 0
user 6 access 0
user 7 access 0
user 8 access 0
user 9 access 0
local 0 transaccess 2
sslsvr 0 certfile “cert01.pem”
sslsvr 0 keyfile “privrsa.pem”
ssh 0 hostkey1 “privSSH.pem”
ssh 0 nb_listen 5
ssh 0 v1 OFF
cloud 0 ssl ON

Power Up Profile: 0

Command: ppp 1 ndis ?
Command result

What does a “modemstat ?” show?

(for reference mine works perfectly using “sendsms 49170xxxxxxx testmessage”

I’ve removed the IMEI etc data from the string

Outcome: Got modem status OK:
Time: 16 Oct 2014 19:07:53
SIM status: Ready (PIN checking disabled)
Signal strength: -93 dBm
Radio technology: UMTS
Signal quality (UMTS): RSSI -93 dBm, Ec/Io -4.0 dB
Radio band: WCDMA 2100
Channel: 10639
Manufacturer: Sierra Wireless, Incorporated
Model: MC7710
Firmware: SWI9200X_03.05.24.00ap r5792 carmd-en-10527 2013/05/02 13:35:47
Bootcode: SWI9200X_03.05.24.00bt r5792 carmd-en-10527 2013/05/02 13:28:17
Hardware version: 10
APN in use: Context 1:
GPRS Attachment Status: Attached
GPRS Registration: Registered lac:0321 ci:0001DEF2
Network: BASE business, 20620
Preferred system: Auto
Network Technology: HSDPA+/64-QAM/HSUPA OK

I’ve tried the command you’ve listed before. That was the 2 times it actually did send a message (out of 10+ tries with the command).

Well I am running short of ideas for forum posts.

What is the format you are receiving the SMS in the event log? For example:
I sent “Test back” from my mobile phone:
19:25:24, 16 Oct 2014,SMS Received: 49170xxxxxxx: Test back,Not executed

Do you have access to another providers SIM to test with such as something on or

I would suggest escalating this through your distributor.

Same format as yours.
I’ll try to get hold of a sim from a different operator, but since the sim works fine in a cellphone it shouldn’t make a difference…?
The problem is that the area in which the modem will be used only has antennas from the operator of the current sim.

This is the point where you may need to turn to technical support.

Trying another carrier’s SIM will allow you to narrow down where the fault is occurring.

From there you can at least know that the transport is working correctly but not in your specific configuration.

I would suggest firstly trying another carrier’s SIM.
Then I would try another SIM from the same carrier but using a different platform such as their prepaid range:

Well i was writing a technical support ticket before i made this post…
But i needed to pay 90$ to be able to do so and i don’t want to spend more money on it yet…

For the €20 it will cost for two SIMs (a prepaid on another carrier and a prepaid from KPN) to test that might be a good shot first.

If you bought the device from an Authorised Distributor you should be able to access their technical support who can escalate it and liaise with Digi on your behalf.

There is a method to virtually detach the com port from the cellular module, link it to Digi Realport software, connect to the module on your pc and then send commands directly to the internal cellular module completely away from the TransPort but that is not something we can go through on the forum.

Can you explain your use case of this device? Is it just one device or will there be multiple and if so how many?

I’ll send an email to the supplier.
The use case: Receivers for fish tracking tags are mounted on the ladder support of an offshore windmill. The modem is connected to said receiver through the RS485 connection. The scientist should be able to receive the data from the device through the cellular connection.
At the moment 4 receiver-modem pairs are going to be installed, this might increase in the future.