How troubleshoot no data, despite Device Cloud connection?

My XBee S6B is connected through my router to Device Cloud. The XBee is attached via a SparkFun shield to my arudino which is sending a stream of integers to my serial port, confirmed via the serial monitor.

But my Device Cloud raw data shows “No data.”

Despite skimming much of the Digi documentation, I cannot find a simple example of configuring the XBee to ensure that data is streamed. I’ve tried various XBee configurations, but no joy.

Any suggestions would be very much appreciated. Thanks!

I have the same problem, S6B connected to the router but no connection to the cloud. I have made an update to newest firmware 2024 and still the same.

The MAC address looks wired in XCTU … many 00000… in front. The one I have entered to the cloud is directly from the router and the unit was added but still no connection.
I have even forwarded the port… still nothing.

EDIT: I will answer myself… be sure you are logged to a right cloud US or EU website… In my case that was my mistake…

No body yet found an answer for this problem?!!!