I can't use AccelePort RAS8 (rev 10)

  • I use CentOS 4.3(redhat AS4 clone)
  1. I download 40002059_j.src.rpm
    rpmbuild --rebuild 40002059_j.src.rpm
  2. so I make dgdm-1.1-6.i386.rpm
    rpm -ivh dgdm-1.1-6.i386.rpm
  3. but I can see error messages(/var/log/messages)

kernel: dgdm: Unknown parameter `-s’
ernel: dgdm: dgdm-1.1-6, Digi International Part Number 40002059_J
kernel: Debug: sleeping function called from invalid context at include/asm/semaphore.h:107
kernel: in_atomic():0[expected: 0], irqs_disabled():1
kernel: [] __might_sleep+0x7d/0x88
kernel: [] acpi_os_wait_semaphore+0x76/0xe0
kernel: [] acpi_bus_data_handler+0x0/0x1
kernel: [] acpi_ut_acquire_mutex+0x5d/0x70
kernel: [] acpi_get_data+0x2f/0x62
kernel: [] acpi_bus_get_device+0x1d/0x2e
kernel: [] acpi_pci_link_get_irq+0x1b/0x68
kernel: [] acpi_pci_irq_lookup+0x39/0x5e
kernel: [] acpi_pci_irq_enable+0x82/0x14b
kernel: [] pcibios_enable_device+0x14/0x16
kernel: [] pci_enable_device_bars+0x16/0x22
kernel: [] dgdm_found_board+0x1bc/0x3e2 [dgdm]
kernel: [] dgdm_scan+0x15/0x274 [dgdm]
kernel: [] init_module+0x56/0x1cc [dgdm]
kernel: [] sys_init_module+0xe9/0x1d0
kernel: [] syscall_call+0x7/0xb
kernel: ACPI: PCI interrupt 0000:04:02.0[A] -> GSI 3 (level, low) -> IRQ 3
kernel: dgdm: found 1 boards.
kernel: dgdm: board 0: AccelePort RAS (rev 10), irq 3, addrs: 0xdf400000 0xdf800000 0xdf3ff000
kernel: dgdm: dxb structure (53684 bytes) is aligned at cafd0000
kernel: dgdm: Configuration: 8 port, DAA type 0, operating little-endian.
kernel: dgdm: POST issued 2 info records
kernel: dgdm: Info 0001: 0000 00000064 00000000 00000000
kernel: dgdm: Info 0004: 0000 00000000 00000000 00000000

  1. then I can send fax only once.(i use efax)
    Never I can send fax later.
  2. what is the cause?
  3. inform a solution please

ps. sorry my poor english

Message was edited by: ironiris

More information is needed:

  • What signals are shown for the modem port withing dpa.dgdm during the time you cannot fax?

  • What inititialization strings are being sent from efax? Specifically, the hang-up string.

  • Is there a log available within efax that will show debugging information? If so, please post.

efax log and dpa message
You can see inititialization strings in efax log

A couple things stand out to me here.

First of all, in the dgdm.txt file, I see Xon/Xoff (software) flow control set on the port. RTS/CTS (hardware) flow should be used, since that’s what modems should use. This will more than likely be found as a setting option in your fax application config file.

The other thing is the following error message from the efax log:

efax: 13:10 command “DT3099”
efax: 13:10 waiting 120.0 s
efax: 13:12 .609 [NO DIALTONE]
efax: 13:12 response “NO DIALTONE”
efax: 13:12 Error: dial command failed

This tells me that we’re not seeing dialtone, which means either the line is incompatable (PBX line maybe?) or an X0 needs to be added to the init string. Have you tried this on a standard POTS line if one is available?

thank you.
I can send fax with init. string (X0)

Excellent! Glad to hear it and thanks for letting us know how that worked for you :slight_smile: