Interference from WIFI?

Is it possible that WIFI networks interfere with xbee communication?

The reason I’m asking is that I was using series 1 wire antenna modules for an installation and things worked well for a while. After some time I had to come back because something broke.

I swapped the xbees for newer ones with chip antennas and it worked again. There were 2 clues i got from this:

  • There was a strong WIFI network which wasn’t there before.
  • The chip antenna xbees had a newer firmware 10E6 as opposed to 1084 in the old ones.

I now updated the other xbees to 10E6. I hope this eliminates the difference. Still, I’m very curious if the WIFI could have anything to do with it. If so, are there xbee settings which would be relevant to minimize this?

This is just some speculation, perhaps someone with more knowledge in the area can add more info or make sure I am correct.

802.11 and 802.15.4 can interfere. When forming the network, the coordinator will do an energy scan and select the best channel. However, once it has selected the channel, it will continue to use this moving forward, despite the environment changing by something like the introduction of a wireless network.

Perhaps by upgrading the firmware the series 1 nodes ended up moving to a new channel with less interference from the WiFi.

I attached an image showing the frequency bands for some of the most common wifi channels, along with the frequency bands for 802.15.4. I highlighted 4 channels from 802.15.4 that have the center of their frequency bands free from the more common 802.11 channels.

It might be interesting to query your network to see which channel it is running on now in the presence of the 802.11 network.


Thanks a lot this seems like its really worth looking into.

I’m not sure how I can query the network to figure out the channel it is running on. (I’m using a machine running OSX and Linux)

Are these channels related to the ATCH setting?


Yes, CH should end up being the channel that the nodes communicate on.

There is quite a bit of detail about how the network is formed and other information in the manual as well:


Aha a classic example of RTFM :0)

I’ve only read the information I found on various website about xbee configuration. Never realized there was such a clearly written manual available! A lot of things have become clear now.

I think I should configure one of my xbees as a coordinator which can change its channel to the best available frequency. The other 2 can be configured as end-points.

I will not allow them to change their PANID since I don’t quite understand how that would work if some other installation next door is using xbees configured similarly. From what I understand this could lead to trouble when my network is hooking up to someone else’s modules.

Thanks again for you help.

All that has been stated are good ideas, but I think that this is not the original cause of the problem. Yes, the CH parameter can be queried using the ATCH command, and everything said about interference is true, except that the 802.15.4 modules (unless specifically configured to do so with the A1 and A2 parameters) will not perform the active scan. The 802.15.4 modules will simply operate on the default channel (xC).

This would indicate that unless you have specifically set the radios up to do some scanning of frequencies, channel xC will be the channel used by not only the radios with issue, but also the new replacements. Which might indicate that either the interference then went away with the new modules (unlikely) or you need to check out your suspect modules.

I’d connect the modules to the X-CTU program and just see if they respond correctly to the Read command. If one or both didn’t, the firmware may have become corrupt somehow. If so, you can use the X-CTU to reload the firmware on your module, which should get it working again.

I had all channels configured to xE, just because I felt it would be a good idea to change the default since the chances of other xbee networks being around are big.

The only difference then would be the firmware. I’ve had all modules connected to X-CTU to read, and also write the new firmware to the older ones. All modules seem to be working.

The problem is I can only test these things in my own lab. Soon I will go back to the site of the installation, and then I’ll find out if things are really working as expected.

Btw I’ve now tried to enable the active scanning, but didn’t manage to communicate with my end-point. I can see from the associate led blinking that the end-point is associated with my coordinator, but I can’t get it to respond to my messages. I already posted this in another thread…