issues running gdbconnectme.raven

I am following the instructions in Chapter 2 of NET_Works with GNU Tools Programmer’s Guide and have ob- served the following: 1. When I run gdbtk -se image.elf the prompt does not return. The instructions state the ‘gdb’ prompt will appear. If I run the same commend in the background (&) of course I do get the prompt back (not a gdb prompt). I do not see a command line option in the gdb GUI. 2. When I execute the gdbconnectme.raven script, I see a number of errors, then the shell bails out on finish- ing the script (attached). I have been told the form- er developer used this script successfully. bash com- plains about: bash: define: command not found bash: target: command not found bash: monitor: command not found bash: monitor: command not found bash: monitor: command not found bash: end: command not found bash: define: command not found bash: gdbconnectme.raven: line 71: syntax error near unexpected token (' bash: gdbconnectme.raven: line 71: set $bcomm = ((struct bios_comm *)0x08000400)’ So, since my .raven file quits it seems reasonable that I won’t get to a debug session. OcdLibRemote does come up and the hyperterminal seems to be getting connected. Thank you!

  1. The prompt should not return into your shell. It will return only after you close the GDB Gui. What were they talking about is the prompt from the GDB console - different window. If you don’t see the command line in GUI, you probably have opened only the source window. From this window you should use the menu View->Console to open the console window. This is were the gdp prompt is. 2. You probably run the commands from the GNU shell. Move to GDB console.