List index out of bound and address violation

I’m a beginner in both Dynamic C language and software. To be more at ease, I tried to personalize Dynamic C theme and while loading color .rgb scheme to edit synthax color, I made a mistake. Since then, when I start the software, an alert says: List index out of bound (-1) before it launches. Then, when I try to open a file, I have an other error: Access violation at address x in module ‘VCL50.bpl’.
If I directly launch the software with a .c file and I try to close it, I have yet an other error: Access violation at address x in module ‘Dcwd.exe’.

I tried to uninstall/reinstall the software multiple times, using the default uninstallator and CCleaner to clean afterwards, but the error persists and I suspect that the software configuration files aren’t deleted.

Is it a known issue ? Is there a way to solve it?

Try the following:

  • Uninstall Dynamic C
  • Launch the Registry Editor (run regedt32)
  • Delete the entire “HKEY_CURRENT_USER/SOFTWARE/ZWorld/DCW” tree. My guess is that the “Rabbit/9.62/Environment/TextStyles” section (or whatever version you installed if not 9.62) has some bad data.
  • Reinstall Dynamic C

Thank you for the quick answer. Since I was in a bit of a hurry and there was no data on the computer used, I just did a quick reset and it worked.