MicroPython XCTU: part of sys module with attribute errors

I´m using an Xbee 3G Global: “Firmware version 11309[Factory] MAC only Oct 6 2017 13:54:08”.

In the MicroPython Terminal, I have got:

MicroPython v1.9.1-538-g22df23d on 2017-10-06; XBC 3G Global with EFM32G
Type “help()” for more information.
>>> import sys
>>> sys.implementation
(‘micropython’, (1, 9, 1))
>>> sys.version
>>> sys.stdin
Traceback (most recent call last):
File “”, line 1, in
AttributeError: ‘module’ object has no attribute ‘stdin’

It seems that a part of the sys module is no more here (stdin, stdout, stderr and modules). This module worked fine with a small code. But after loading a larger code, it went wrong. An update of the radio module firmware doesn´t help. What wrong did I do and is there any solution ?

The sys.stdin feature wasn’t included in the 11309 release, but will be in the next (1130A) release. It is present in the 100A and 3100A releases for LTE Cat 1 products.

I do not know the scheduled release date for 1130A.

1 Like

Thanks for your answer.
I used sys.stdin and sys.stdout in the 11308 release first and it worked well within a small code size. Then I loaded larger code with some problem like memory allocation error, buffer full… I have the feeling that I removed some part of library or python modules by loading my micropython code. Then I updated to 11309 with the result you know. What is the maximum micropython loadable code size and is there anything to do/know in order not to remove anything ? Thanks.

Later this month there should be a 1130B release that includes support for a file system and modules that you can “import” into your main program. Perhaps that will help with your code size limits.