Module Import question

Greetings all,

I’m new to the Digi ESP Python environment (though I’ve worked with Eclipse before) and I’m having loads of trouble even getting the examples to work.

I performed the ESP basic install from the web and attempted to run the XBee examples locally and it appears that there are modules missing as I keep seeing “No module named xbee” any time I try to import it.

I am attempting to run the application on a ConnectPort X2 we had laying around the office and managed to find, upload it to the unit, and run the tutorial code where it prints “Hello Digi World” x5, however any time I try to include xbee modules it dies.

What zip files do I need to upload to the device? What else should I know about this? I know this is a simple problem but because of my inexperience, the solution eludes me. Any and all help would be most appreciated. . .

Hello Jpod1313,
As you said, you won’t be able to run any XBee python example locally since local machine doesn’t have an XBee stack available to work with, and that is the cause of the problem.

However, running any other kind of python examples on remote devices with XBee stack (which is the case of the ConnectPort X2) should not give any problem.

If you are getting errors while launching XBee examples in your ConnectPort X2, it may be because you have an old firmware version installed. Old versions of firmware require an additional python file to run XBee examples, that is the

Please, find attached the file and the file that should be uploaded to your device before running an XBee application.

If after uploading these two files to the device you are having trouble running XBee examples just reply with the error stack.


Thank you very much descalon, that solved the problem. I didn’t know _zigbee was an available built-in module!

I am having another problem, but I will post it in a different thread as this has been resolved. For some reason, the attachments on others’ threads seem to have disappeared, otherwise I think I might have found these elsewhere.

If you have time, please check out my other thread; I’ve run across a nasty problem I can’t solve :frowning: