Monitoring and controlling a led light using an XBee.


I’m trying to monitor the state of a LED light, as well as turn it on/off manually. The led it connected to a switch. On the + side of the LED light, I have D0 configured to change detect, and D7 which is always high (to turn the led on when the switch is on), as well D3 (which is my “force control” - if the switch is off, I still want to be able to turn the led on).

When D3 is attached to the positive side, the change detect won’t work. If you remove D3, the change detect will work as expected.

How can we solve this to be able to have both change detect (monitoring) and a “force control” to manually control the led light?

It’s also worth mentioning that the LED light “lights” ever so slightly when the switch is turned on, and the manual control is off. When the manual plug (d3) is removed, the led shines brightly again.

Any help would be greatly appreciated.

Which XBee product and firmware are you working with?

I am working with XBee S1.
XCTU Firmware version 10ec (6.3.0)

First off, upgrade your firmware. The version you are working with is 4 versions behind.

Next, change the IC value so that you are not monitoring any lines you do not want to use. Also make sure that you have the proper level conversion in place as the radios line can only tolerate 3V.

D0 is the only line I want to monitor for change detect, so I have the value 1 in IC. D7 is always high to turn the led on when the switch is pressed. D3 is disabled as it’s my “force control” - controlled by API frames.

I’ve pressed “check for updates” in my XCTU, but nothing happens.

The XBee radio is connected to 3V.

Edit: Firmware has been updated to the newest version.

what version of XCTU are you working with?

D0 is configured as a Digital In right?

After checking for updates, it still says Version: 6.3.0
Build ID: 20151110-8

I updates the XBees as well as the radio firmware library.

Yes, D0 is DI.

Change detect worked perfectly until I added the D3 which I could set high or low in my program. Even with this added, but not plugged to the pin, the change detect worked fine.

Change detect works fine until manual control is added. Manual control works fine if Change detect is removed. They don’t work together, but both works on their own.

Try using the XBee Recovery function in XCTU to updated to the 10EF firmware version.

Will it work simply by updating the firmware?


I suspect it will.

Why I can;t tell you. But if you are generally having issues, the first thing I would do is see if there is a newer version. If there is, I would update to make sure that something was not fixed.