Need help configuring PortServer II access to Linux console on i.MX53

I am using a PortServer ll (fairly certain “without RealPort”)

I am trying to connect to console of i.MX53 board running Ubuntu Linux. I have verified the board powers, runs U-boot then boots Linux. All the console traffic appears via a USB-serial dongle connected to host (OS X).

Yet, I am unable to connect with 'telnet 2001` to the i.MX53 console port.

The cat5 is connected to Port 1 on front of PortServer and to an official Digi TS Console Adapter part # (1P) 63000086-01 B. I also added a male-male gender changer to accommodate the i.MX53.

I performed part one of the diagnostics (described in Testing and Troubleshooting a PortServer guide); and it worked as expected.

I made a loopback connector according to the Digi documentation. I am successfully able to telnet to IP address; then connect 8 to port 8 which is configured for loopback operation. It works.

Please offer a suggestion for a fix or recommend troubleshooting tasks. That would be super helpful! :slight_smile:

Here are some general configs and settings for port 1:

#> cpconf term
# PortServerII Version 3.1.13 Nov  1 2006
# ROM version 106, Amount of RAM: 4 Megs

set tcp realport=771 rto_max=240 sockets=2000 keepalive_idle=02.00.00
set tcp probe_count=10 probe_interval=75

set radius authentication=1645 accounting=1646

#> set ports ra=1

serial# termtype dev   sess uid edelay auto bin group dport dest             
  1     vt100    prn   4    0   1      off  off 0     0          

#> set line ra=1

serial# baud   csize parity stopb break   error   inpck istrip onlcr otab 
  1     115200 8     N      1     ignore  null    off   off    off   off  

#> set flow ra=1

serial# ixon aixon ixoff ixany itoss altpin rts   dtr   cts   dcd   dsr   ri   
  1     on   off   on    off   off   on     on    off   on    off   off   off  

#> set config
PortServerII Version 3.1.13 Nov  1 2006
Copyright 1990-2001 Digi International. All Rights Reserved.

myname        :                            domain           : 
ip            :               submask          :  
gateway (LAN) :                nameserv         :        
boothost      :               bootfile         : 40001260_af.bin
ether         : 00:40:9d:24:1d:37          icmp redirects   : ignore
bootpserver   :                            bootpgenericfile : 
bootp         : no                         tftpboot         : no

Many thanks to everyone who took the time to read!

It turns out the port is configured properly. I tried two other embedded Linux boards from different manufacturers (which did not require the gender changer). Those work fine.

I still do not know why the i.MX53 does not operate with this port.

As unlikely as it may be problem; the gender changer is the only other difference in datapath.

Artie :slight_smile:

It appears the port is configured to use both software and hardware flow control. I recommend turning off hardware flow control in the event the cable is not wired for it as this would prevent communication on the port.

set flow cts=off rts=off

If this does not work, please post the pin-outs for your cable.

Thank you quite very much for your response.
I hope that I am answering the question correctly.

The pinout diagram for connector 76000697 is:

Are there any actions or tests which may yield additional information?

thank you!

Port     TD    RD    RTS   CTS   DSR   DCD   DTR   RI    OFC   IFC

   1     off   off   off   off   off   off   off   off   off   off

How does this forum supposed to operate?