NET OS lock up at 97% in debug mode

I am debugging a project and everything was fine. After a change in my code and a rebuilt, the NET OS 7.4.2 stuck at 97% of the debugging process. The code is sent to my device (connectcore 9C), but nothing is happening.

I have tried another project, and it is working fine. the changes i have done in my code cannot influence this since it is in my custom file.

I have rebooted, delete all files in my debug directory, but it is still happening!

any idea?

i too had the same prob before. but closing the Segger J-Link GDB Server window & then a clean and rebuilt resolved my issue…

But i would recommend to check etehrnet cable plugged correctly.
Are you sure your program is being downloaded to 9C module ? Can you see the logs in GDB Server window?
At the end the log should say - waiting to start the processor

I am using USB JTAG and the usb works fine.

I have tried another project and it is working. Any idea what could cause this? It is not even executgin my custom files yet at this point?! And it was working fine until this afternoon!!



When I see such behavior, the first thing I ensure is that the platform for which I am building the project is the platform I am downloading to. If the wrong platform is selected, the wrong debug script is used and thus chip selects et al could be set up incorrectly for the platform in use. You would see behavior as you describe.

Also ensure that the code you added has not increased the size of the project beyond what your platform can bear.