NET+OS Programmer

I’m trying to load a firmware in a Connect ME -C module using Netosprog.exe.

But I get always the error: “FtpPutFile failed with error 12030”

Please, someone knows what mean this error?


Hello it is standard error code
12030 ERROR_INTERNET_CONNECTION_ABORTED The connection with the server has been terminated.

There should be mote things wrong (bad password/login, firewall …)

Netosprog is ftp uploader. Try to open ftp connection via totalcommader ( install it and hit ctrl+n give ip ad uncheck anonymous connection and hit OK, then fill up username (root) and password (password) and then you should be in. If you want to upload new FW just copy image.bin into the ftp and close the connection. Just be aware copied image is not visible on the ftp!


Hi kubiajir,
I’ve just tried to copy the new image (image.bin size:390.438) using a ftp client (filezilla).
It looks like my digi module doesn’t accept the image.bin file.

Here the FTP logs:
Command: STOR image.bin
Response: 150 About to open data connection
Error: File transfer aborted by user after transferring 390.438 bytes in 1 seconds

NB: But with FTP I can transfert any other file


Try the total commander, I now tried filezila and works strange with me.

Another question is the DIGI module clear or you have downloaded some image before?


Hi kubiajir,
I’ll try commander as soon as possible.
The Digi is not clear, I’ve downloaded some image before.


I didn’t see the reply, so here is my two cents.

  1. Did you include the FTP in the image you did before?
  2. Do you have enough RAM free to cache the image before writing?
  3. Is it a generic ME or a 9210 ME? 9210 MEs have a TFTP auto-recovery. (the really old MEs have a recovery console as well)
  4. Do you get a checksum OK message when you FTP?
  5. Remember to wait up to five minutes after FTPing the image.

Hi egawtry,
I know what I did wrong.
In my file customize.ldr, I’ve set BACKUP_RECOVERY_MAX_SIZE_IN_FLASH = 0.

Probably for this reason, I can’t recover my module…


This should not be the problem. Tha main problem can be the FTP. Which command do you use for ftp initialization?

I using naFtpFSInit() which enable FTP in flash and image uploading to DIGI.


Hi kubiajir,
I’ve got 2 modules.

First module with my application and BACKUP_RECOVERY_MAX_SIZE_IN_FLASH = 0.
This module works with my application, but I can’t load anymore application (image.bin).

Second module with my application and BACKUP_RECOVERY_MAX_SIZE_IN_FLASH = 448K.
This module works with my application, and I can load any other application without problems.


I tried to set size of backup image via IDE and the lower size is 64K. Can set zero.

You should contact DIGI for support, because this can be a bug in NETOS.

Anyway you can do failsafe recovery for the module follow this:

In fact, I’ve set BACKUP_RECOVERY_MAX_SIZE_IN_FLASH = 0 directly by editing customize.ldr file (without using IDE)

I’ve already tried the failsafe recovery , but didn’t work.
The procedure says:
Now, if the the image doesn’t work BUT has a valid image header AND passes it’‘’'s CRC check, then this procedure can’t occur, the unit still won’t boot, and the module will need to be RMA’d.

What’s stange, that my module boot perfectly and start my application OK. But can’t update a new firmware !

Do you know what means RMA’d ?


RMA is Return Merchandise Authorization. Try contact digi via they will tell you what to do.

Long time ago i had ME9210 modules with damaged rom image and it didnt load new firmware in failsafe state. But update of rom.bin fixed this problem.

Now I have in every backup image, because if something happen on site is difficult to do failsafe recovery…


Thanks for the info, I’ll contact Digi.
And in the futur, I’ll add too a backup.img.


I’ve got another question for you.

In my project I’ve define a flash filesystem with this size.

But in reality in my filesystem I can download (via FTP) about 500K of files only.

Do you know this problem ?


This is because the filesystem takes up some memory for file allocation tables.