openvpn TRANSPORT WR31


A while back I send some questions about OpenVPN with my WR31. After a while it seemed that it worked OK as I could connect to my OVPN server (ubuntu 16) with the digi router as a client.

It connects but only about 1 time every 100 times. Most of the time I can see that the TLS authentication transaction configuration is starting with my server. But then the router crashes and restarts. I can see that as I have to re-log every time on the Ethernet graphical interface, and the mobile network has to be re-established.

I think my setup (certificates, key) is OK as it can (rarely, but it can) connect to the server. I tried to look for all the time-outs settings that could cut the connection but everything I tried gives the sames results.

I also think that it shouldn’t crash (or restart) like that, is there a bug? I get this behavior with two WR31. It seems even worth on a different mobile network (different provider) than the one I use usually, maybe it is slower.

The log file doesn’t give any useful information, I just see that it is trying to start openvpn.

Below are the settings I use, on top of that I load the certificate in the X.509 Certificate Management tab.

Any hints or recommendations are welcome as I am completely stuck at the moment.

sslcli 0 certfile “user.crt”
sslcli 0 keyfile “client.pem”
sslcli 0 verify 10
ovpn 0 descr “xxxx”
ovpn 0 IPaddr “”
ovpn 0 dest “”
ovpn 0 do_nat 1
ovpn 0 autoup ON
ovpn 0 pullip ON
ovpn 0 pullroute ON
ovpn 0 pulldns ON
ovpn 0 pingint 10
ovpn 0 pingto 120
ovpn 0 cipher “AES-256-CBC”
ovpn 0 tlskeyfile “ta.key”
ovpn 0 tlskeydir 2
ovpn 0 treplay 60
ovpn 0 proto UDP
ovpn 0 metric 20


What firmware version on the router.

I would see if you try a earlier version of the firmware.

if that works then report it to as a BUG

you will need a DEBUG.txt file from the router and might also need the version of Ubuntu and version of Openvpn



did ever get this fixed? I am having the same issue with WR31, Digi told me that the Firmware update would fix a bunch of issues but so far my connections is the same, it keeps dropping after a couple minutes.


i can confirm that openvpn is not working anymore with firmware 6.x.
With Firmware it was working flawless.
After vpn is connected the router restarts every minute.(vpn auto connect)

Without the vpn-connection the router runs normal.

I will now try the downgrade… did run as expected. seems to run, it is now running 7 Minutes…


I never fixed it. I tried switching firmwares to different versions (I don’t remember which) with no success. At some point a firmware update went wrong and I couldn’t use the router anymore…

So we went to a different vendor


… we went to this vendor :slight_smile: is working…