Port Sharing

Hello anyone.

I’m testing at the moment Port Sharing capabilities for the Digi One SP device.

From the Digi One and Port Server User’s Guide I went to configure more than a user for the serial port at the Console management option (Page 23), but I noticed that this option doesn’t exist for my DIGI ONE SP device.

Is this a firmware problem ?

Does the device support this capability ?

I saw at Redundancy in Serial-to-Ethernet Communications document that Digi One SP supports Port Sharing since December 2004.

Additionally, I think of testing this feature for the PortServer 8/16. I saw that J release supported Port Sharing. Could I have the same problem with new PortServer 8/16 units ?

Please let me know how to proceed.

Thanks in advance,

Ignasi Villagrasa.

Port Sharing was not added until the 82000774_G (latest) release of the firmware for the Digi One SP. If your unit has anything older than that you’ll need to upgrade in order to use this feature.

As for the Portserver TS8/16, firmware 82000684_J or later will support Port Sharing, but I’d recommend upgrading to latest firmware due to several sharing-related fixes which appeared in later versions.


We have some Digi Portserver TS4 MEI’s here and I was wondering about the same thing. I would like to be able to have multi Telnet sessions to the same serial port.

Is this possible? Do I have to upgrade the firmware also? If so is this very safe, I am concerned if I flash the unit wrongly I might make it in-operable.

Also can anyone help with a source of Digi part number 76000701 (4x Modem cables) for the TS4/8 series. I have had no luck finding a suplier that will ship to Australia. Cost of these is usually around US$14 per pack as per google searches.


Port Sharing was added with the 82000747_N firmware release for that product. There was also a port sharing bug fixed in a subsequent release, so best idea would be to load the latest firmware available and see how that works for you.

As for the cabling issue, we do have “Buy Online” links on the cable page if its possible to use them. Otherwise you’ll need to check with your Digi Sales rep.


Yea, I tried flashing one of the unit’s to the latest release. Worked OK. Was quiet interesting all the changes since the early release that was in mine. Infact it was nice to see all the development done. I do still wish they’d include SLIP again though.

Anyhow, even with the flash upgrade I couldn’t get the portserver to allow multi connects to the same port from different telnet sessions. Perhaps there is a setting somewhere that needs changing… If so I haven’t been able to find it. I have set Max clients for that port to 10. But if you try to connect to the same port a second time from a different telnet session it says. `Cannot open this port or hunt group.'.

As for Cables, I’ve tried this too. The DigiStore shop does not cater for international orders. Quiet frustrating. I can get as far as entering the delivery details. But then it says they can’t accept international credit card’s. There is also no where to enter the country in the mailing address etc. Not to mention a way to get a shipping quote to Australia.

The cables part number is 76000701 for a pack of 4 cables. They sell for anything from US$14-$19 per pack at different online stores. (Digi Online US$19 per pack).

IF someone can help me out, I require 3 pack’s which could easily be dropped into a USPS Global Priority Mail - Flat-rate Envelope for under US$10 to Australia.

Payment can be made via PayPal or Visa Card my end.


I’m not sure where you’re able to change Max Clients for that port to 10, since the maximum the Web UI will allow you to set is 4. This setting is found via the Web UI under Configuration > Serial Ports > port # > Advanced Serial Settings. The field name is entitled “Allow multiple systems to simultaneously connect” (check the box), with a dropdown of the number of simultaneous clients allowed right below that.

As for the cable dilemma, try contacting Anderson Lei at 852-2235-222 (Hong Kong). Hope that helps!

Hi, I am running

Model: PortServer TS 4 MEI
Firmware Version: Version 82000747_R1 10/13/2005

Which should be the latest.

There is no “Allow multiple systems to simultaneously connect” option within the Advanced Serial Port settings on my screen.

Also do you have a Email and or Web page address for Anderson Lei please.


I’m not sure why you’re not seeing that option, since I just checked a PortServer TS4 MEI which had the 747_R1 firmware loaded and that one had it. You’ll probably want to contact Technical Support via phone or online support request form at this point so we can look deeper into the issue.

I’ve done a factory reset to try this again. Still no menu option. Is there anything else I need to set before this option should show up on the menu?

OK, I’ve just worked out whats going on.

This option only becomes available if you set the port profile as a `RealPort’ type.

Setting the port type to any other type (In our case Modem is what we wanted) does not allow for the sharing option’s menu to apear.

Is there a work around for this? Or is this a bug to be fixed in future firmware releases?


Yes, sharing would only be allowed when the port is in a passive state, otherwise the Terminal server login blocks it.

I don’t think there’s any workaround for that, but if you contact Technical Support and open a case we could put in a change request for you.

Digi device, supports multiple serial port interfaces, set the interface with the dip switches on the device.