PortServer latency issue

I’m using a PortServer 4 TS H MEI for various duties including connection to a Dallas 1-Wire RS-232 bus master with the Digi in RealPort mode. I’m getting some severe latency with that connection. I’ve got a small network of 1-Wire temperature sensors and a piece of test code that searches for the sensors then reads them all. The code times the search and the reads. With the 1-Wire network connected directly to the computer’s serial port, the search takes under 1 second and the reads take a total of about 0.5 seconds. However, connected to the PortServer, the search takes 10 seconds and the reads take a total of about 5 seconds. Both ports use a BAUD of 9600.

The PortServer has the latest POST (82001178) and firmware (82000747). The O/S is RHEL 5.2 and RealPort driver is version 1.9-17 for Linux RHEL 5.

Pings from the computer to the PortServer are a steady 1ms.

I’ve tried the latency optimization and done the suggested port configuration tweaks, which made only a small improvement. Is that as good as it gets or have I just got it configured wrong? Hopefully the latter.

Have you tried tinkering with the edelay setting? If not, you may want to try the lowest value:

ditty-rp edelay 1 ttyx##

Well thanks, that improved the latency to an acceptable level! I’ll have to look into that option to see what it’s all about. I don’t think the man page mentions it.