Portserver TS 16MEI, Serial Signal Drop

Location where hardware is being used: Ship at Sea
During our last field operation, we were experiencing random spurts of serial data (RS232 and RS422 Alt Pin) being dropped/ becoming corrupted. We would monitor our data via Hyperterminal, which upon becoming corrupted would just freeze. The lights on the portserver would no longer flash showing data activity. The quick fix for this would be to restart the digi portserver (Either by cycling the power or through the web interface).Once the portserver was restarted, we would then be able to monitor our data. We checked all of our cables and data feeds and we believe the problem lies in a ground loop interference with our DIGI portservers. Another Note, we are sending serial string data via cat5e cable with an 8p8c connector on either ends. We have followed the correct pinout as per the cable guide for the Port Server 16MEI. We have hardly seen an issue like this before or even one so persistent. We know our system works.
My main questions are the following:

Would it be beneficial to buy some electro-optical isolators for our serial comm strings? Other Boats have them for their electrical equipment.

Does the Portserver TS 16MEI have any sort of optical/ isolation built into the unit??

Would upgrading the firmware in the field help with this issue?

Furthermore, I compared our config file from the field to what we have here in our shop and some configuration settings are a little different. I noticed that on line 79 (if opened in excel) that error=parmrk . On the PortServer that we have in our shop, our config file has the error set to ‘ignore’. Would this cause the port server to ‘freeze’ if it sees a parity error?

Here is part of the config file that I am talking about:

set line range=1 parity=N csize=8 error=parmrk
set line range=1 baud=9600 stopb=1 break=ignore inpck=on istrip=off onlcr=off otab=off
set flow range=1 ixon=off aixon=off ixoff=off ixany=off itoss=off altpin=off forcedcd=off
set flow range=1 dtr=off cts=off dcd=off dsr=off
set flow range=1 ri=off
set flow range=1 pre-delay=0 post-delay=0
set flow range=1 rts=off

Their is also an other variation of the error setting where it is set to ‘DOS’ instead of ‘Ignore’ or ‘parmrk’ further on in the config file.

Any help would be greatly appreciated.