Problem configuring WiFi Xbee - can't even connect to it reliably

I just received my Xbee WiFi Cloud Kit. I’m using a laptop with Windows 7.

Following the directions in the “XBee Wi-Fi Cloud Kit Quick Start Guide”, I plugged the WiFi Xbee onto the Development Board and connected the USB cable. My laptop sees the Xbee as a Wifi device (xbee xxMAC-IDxxx) and can connect to it.

The problem is trying to configure it to talk to my AP. In Chrome browser, using the IP of fails to connect unless I disconnect and reconnect to the Xbee in the computer’s wireless network settings. About 1 out of 5 tries the entire WiFi configuration menus comes up. The rest of the time it either gives “The web page is not available” or only part of configuration menu shows. If I finally get the configuration menu and attempt to configure the AP settings, when I hit “Apply” there is a long wait onlu to get “The web page is not available” and I have to start over.

The laptop is right next to the Xbee and Development Board. I’ve disabled Windows Firewall. Digi Device Discovery can’t see the device even though the computer is connected to it.

I can’t figure out why I can’t get a reliable connection between the Xbee and my computer and I haven’t even started fiddling with Device Cloud 8 (

Thank you!

Resolved (if not totally solved). I connected the Development Board to a USB wall wart instead of the computer. Everything worked.

Not sure why the computer got confused when the USB cable was connected between the Dev Board and the computer.


You might want to try connecting the external power for configuring. I’ve seen instances where the USB power is not sufficient.