problem connecting two XBee modules

Hello everyone,
I searched and didn’t find a similar question in the forum.
I have a pair of XB24-Z7WIT-004 modules. I have connected them both to my laptop through USB adapters.
This is product family, function set, and firmware version I’ve flashed into them using XCTU:
XBee #1: XB24-ZB, ZigBee Router AT, 22A7
Xbee #2: XB24-ZB, ZigBee coordinator AT, 20A7
The configuration values for the coordinator are:
ID(PAN ID) = D161
SC(scan channels) = F
NJ(node join time) = FF
CH(operating channel) = E
SH(serial number high) = 13A200
SL(serial number low) = 40CAB14B
DH(destination address high) = 13A200
DL(destination address low) = 40CAB136
The configuration values for the router are:
ID(PAN ID) = D161
SC(scan channels) = F
OP(operating PAN ID) = 0
SC(scan channels) = F
CH(operating channel) = 0
SH(serial number high) = 13A200
SL(Serial number low) = 40CAB136
MY(16-bit network address0 = FFFE
DH(Destination address high) = 13A200
DL(destiantion address low) = 40CAB14B
They both have their power level set to 4 (highest) and they are both turned on. But as you can see, router’s network address is 0xFFFE which to my knowledge means it’s not joined a network. And the communication doesn’t take place when I open up two serial connections in XCTU. What am I doing wrong? Is this setup even supposed to work? Any help would be appreciated.


That is incorrect. You need to look at the AI command as well as the OP and ID values.

In this case I can tell you are not associated based off of the channel value as well as the OP. Try doing an ATNR0 on your coordinator and then see what channel it comes up on and then check your router.

Digi Support

Thanks for answering
I issued these commands on a serial session with coordinator:
after that I read the configuration parameters on the router. No change. OP is still 0 and AI has value FF. Also on coordinator AI has value 0

Now issue an ATNR0 on your router. But make sure both have antennas, are powered up and within range of each other.

I went through the procedure over again. I issued the commands for coordinator. This time it obtained channel E. While coordinator was still on, I issued ATNR0 on router and got response OK. But ATCH is returning 0. AI value is still the same as before for both.
But one thing I noticed was that RSSI LED on my usb-serial-adapter connected to coordinator was blinking about every six seconds. I disconnected the router from my laptop and the LED on coordinator stopped blinking. I Connected the router again and it started blinking. Then it stopped blinking after a few seconds although router was powered up. I issued ATNR0 on the router and coordinator started blinking again. But configuration parameters like AI, OP and are the same as before.

Try restoring both to defaults (ATRE, WR). Also make sure that the antenna is connected on both units.

After issuing (ATRE,WR) and then doing network reset on both, problem solved. So thanks a lot!