Problem with CPU comsumption

I’m using the iDigi Dia 1.2.19 and the following elements: ConnectPort X4, 3 watchport sensor (H-D-W), 2 Wall Router and a DIO.

the sample rate in ms are:

Wall Router 1 - 5000 (5 sec)
Wall Router 2 - 5000 (5 sec)
Watchport/H - 10 000 (10 sec)
Watchport/D - 3000 (3 sec)
Watchport/W - 3000 (3 sec)

The only presentation i’m using is the “Console Presentation” on port 4146. I even try without it and the problem persist.

The problem starts when i configured all those elements, because the “CPU Utilization” of the X4 reach the 100% level and i think that’s too mucho.

is that normal or i do something wrong?

I upgrade the firmware of the X4 to ver.

Firmware Version: (Version 82001536_F1 10/30/2009)
Boot Version: 1.1.3 (release_82001975_A)
POST Version: 1.1.3 (release_82001753_C)
Product VPD Version: release_82002010_B

At what point did you see 100% CPU utilization? Was this immediately after rebooting the X4 or starting the Dia, or some time later? If so, how long after starting Dia did you see this?

when the Dia is allready running the CPU is in 85%, then begin to raise until 100% and remains that way at all time (I checked pressing the “Refresh” button in the web GUI).

I check, and there is nothing in the “Auto-start settings”.

I probe disabling the presentation seccion and still doing the same.

After rebooting the X4 CPU utilization prowl the 17%

what’s wrong with this?

thanks for your attention!!

I have never used the WatchPort sensors. My X4 has 8 Xbee devices (AIO, DIO, serial) & runs 15% utilization. Some of my devices read every second, others every 15 minutes - but I have them all set to send-in data to the gateway. I don’t think the WatchPort can do that; it must be polled by X4.

One suggestion, if you have newer gateway firmware which supports the over-the-air update of Xbee firmware, turn that off. It can cause “mesh congestion” for many minutes after you reboot the gateway.

Some cellular systems also cause near 100% usage during PPP start-up, so don’t activate cellular unless you need it.

Easiest first test - change all of your poll rates to 15 second, then 60 seconds. See what the effect is.

lynnl i’m no familiarized with the “send-in data” term. Is that in iDigi Dia?

I disabled the over-the-air update of Xbee firmware.

My X4 don’t have the cellular modem, so i don’t know if it’s still activated anyway.

I change the poll rate to 15, then 60 seconds and the problem persist.
The CPU begins at 80% and rise up 100%