Problems using WPA2


I can’t seem to get my 5600W to connect on my WPA2 protected network. I use this as defines:

#define WIFI_USE_WPA
#define IFC_WIFI_SSID “linksys”
#define IFC_WIFI_WPA_PSK_PASSPHRASE “my passphrase”

Thanks! any help would be appreciated.

Hi Chibouraska,

I’ve had the same problems. The security of my DHCP-router was configured as ‘WPA2-PSK / WPA-PSK’. When I changed the setting to only ‘WPA2-PSK’, the problem was solved!

Good luck,


Hi Dennis!

Thanks for a reply, i will try this.  


I’m running an Actiontec MI424WR router (I think this is the standard FiOS router). I had the same problem until I changed the selection for the WPA2 Encryption Algorithm on the router from TKIP+AES to just AES (there’s a little drop-down selector in there). Once I changed it to AES, everything started working just fine. I don’t know why all of my other devices (laptops, iphone, PS3, squeezebox v3) worked with the original setting, but fortunately everything still works with it set to AES.

  • Jay

I have WPA2 Personal on my Linksys router, is this like WPA2-PSK?

Google is your friend…,15736210

It looks like “WPA2 Personal” is the same as WPA2 PSK (per the wikipedia article). The real question is TKIP vs. AES. Reading through this stuff, it look like some routers support TKIP+AES in addition to AES-only for the sake of backwards compatibility with older access points that only use TKIP. The Rabbit libraries support AES… it’s not clear why it doesn’t work when the router is in TKIP+AES mode (at least this is the case with the Actiontec). Probably some subtle bug in there.

What model Linksys router do you have? Can you connect to the router from the RCM5600W when the router is configured for WPA2?

  • Jay

Hi Jay!
I think i will try with my RCM5700 board just to see if a wired ethernet
connection will work, but i douth it. My router is a linksys WRT310N.


I know this is a very old thread, but I was searching for the answer to this exact problem and couldn’t find it anywhere in the forums… But I worked it out now, so I thought I should share. In the ‘tcp_config.lib’ file, version 10.66 onwards, they updated the documentation to cover this scenario.

The reasoning behind it is a bit sketchy, but you need to do this:


Using the bitwise OR on the encryption - I think this makes it negotiate with the access point which encryption to use.

Also works with the runtime ifconfig() function - but I found it only worked if I had no spaces either side of the OR (the documentation shows it with spaces - I am using DynamicC v10.60)