Problems with 7_42 latest updates on 9P 9215

Hi All,

I have just upgraded my development system to NetOS 7.42 and applied all the patches that the ESP package manager can find.

I have simply used the “New/Net+OS Project” to create a basic outline for the ConnectCore 9P 9215, using all the default options provided by the wizard.

When downloaded under the debugger this runs for about 50 seconds and then crashes with the yellow LED on the module flashing. It does seem to work OK if I disable the HTTP Server, and with HTTP Server disabled I can use the FTP server to download an image to the Flash.

Anyone else seen this or managed to work out what is going wrong?

Did you select ‘no’ when it asked you to reboot the ESP?

Try shutting down the ESP, modify the Target in the ESP shortcut by adding a -clean to the end, and then re-start the ESP. Next, do a Platform -> Clean and rebuild your app.

There is an issue with the NET+OS 7.4 SP2 patch in that multiple threads will cause it to crash. This could very well be the cause of the behavior you are seeing with your project. We do have a simple temporary fix for this.

  1. Close your project, exit the ESP
  2. Right click on the ESP shortcut, and then add a ‘-clean’ to the target. For a detailed view of where to make this addition, see the screenshot in the attachment “7_4_2 CLEAN fix”.
  3. Restart the ESP (which will take a few minutes).
  4. Open the project, Do a “Clean/build Project”.
  5. After closing your project, you can then remove the “–clean” from the shortcut target.
  6. Repeat this for all projects you want to run on 7.4.2.


I did say yes to rebooting ESP when it prompted after installing the packages. I have not yet tried the -clean option on the shortcut. Is this still required or did the install reboot ESP with the correct option?

However, I think I may have solved the problem on Friday. I tried disabling various otions in the appservices.h file which did not seem to do very much, but then I noticed the call to UpTime_Init() in initAppServices() in appservices.c. This seems to cure the problem and the basic outline application has now been running for well over 2 days.

Interestingly, the System Up Time display is still working correctly on the home page of the Web interface, so it seems that it is started elsewhere.

I also noticed that the telnet CLI seems to work irrespective of the setting of the call to CLIServer_Init() in appservices.c The serial consolse displays a CLI Started message prior to the the initial breakpoint at the beginning of applicationStart().

In this outline application it is not really clear exactly where either of these services are started, so it looks like a bit of checking with the debugger is called for to see exactly where the calls are coming from to start the Up Time Monitor and the CLI.


I have a recollection of some uptime-related problems when I was trying to get the original flawed 7.4.2 release to work.

Is it possible that you’ve got an old file somewhere, or that one of the bsp/system files that are copied to the project is out of date?


I do not think there are any old files around. I think that I will retry a complete new install. Luckily I reformatted my laptop over the weekend, so currently all it has is a completely clean windows install.

I will re-install ESP from my 7.4.1 disc and then run package manager to get it up to 7.4.2, and try again with the basic outline application, and then post what happens.

The whole upgrade routine is hard work. Currently what I do is to save my code in Visula SourceSafe, then build a standard application from the ESP New Project Wizard, and then use VSS to review the correct way to merge my changes to the standard files. This seems to be the only way to keep in control of things.

Try the -clean fix I mention above, I’m able to get the basic sample working after doing that.

Hi All,

Many thanks for the replies.

I have gone through the reinstall with the following results.

Re-install sequence:

  1. Install from 7.4.1 CD
  2. ESP Starts Automatically
  3. Immediate prompt to update crtitcal Packages (Yes)
  4. Package_Manager_NETOS Update succesfullly installed dalog
  5. Error then shown on main package manager screen
  6. Restart ESP, and run Package manager
  7. main screen shows Package_Manager_NETOS installed, and NETOS_742_SP and NETOS_ESP_742_ESP
  8. Request install for NETOS_742_SP and NETOS_ESP_742_ESP (continue)
  9. Both packages install correctly and Prompt to restart the environment (Yes)
  10. System Restarts
  11. Run package manager this finds a further 5 post 742 updates
  12. Request install for all 5 packages
  13. All packages install ok (see attached .bmp)
  14. Run File/New/NET+OS Project and accept all default settings in the Wizard
  15. Select Build NetNET+OS Application from speed button
  16. Project builds Debug configuration with no errors
  17. Select Debug NET+OS Application from speed button
  18. Debugger launches and downloads application
  19. Select Resume, and hit breakpoit at begining of applicationStart
  20. Application appears to run Ok and shows up in Finder
  21. After 50seconds Yellow LED starts flashing, and has gone from finder
  22. Suspending application in debugger semms to allways stop in System Uptime Thread
  23. Edit sys/appservices.c to and comment out call to UpTime_Init()
  24. Rebuild and restart in the debugger
  25. Application runs correctly and Web interface displays System Up time incrementing
  26. Changed Digi ESP shortcut as specified by sbrown above
  27. Removed comments to re-introduce call to UpTime_INit() in appservices.c
  28. Run Project Clean
  29. Build Project and run in debugger
  30. The project appears to run Ok (comes up in finder, and Up Time updates in Web page).

The “-clean” fix cures the problem and the basic application runs as standard with no problems.

I have not yet investigated the fact that when UpTime_Init() is commented out the application runs OK and the web page updates correctly. Not sure if this means that the call is or is not required.

Also, dos anyone have any info on the icons in package manager as shown in the attached screenshot?

Hello Scott,

I see the same problem with my NET+OS, only that the work-around you have described does not work. My debugging session still crashes with the blinking LED on the 9P 9215 module. Any other suggestions except re-install?

Thanks for your help,


Sorry, file was too big this should be zipped version

I believe you mean the icons on the left. The green check mark means a recommended download, and the triangle with an exclamation mark means a critical download.