Programming modem using DOS prompt

I need make a process for write in modems with minimal interaction of people.
I thought to do using a command line, but i tested with DOS prompt this command and doesnt work:


This commands was sent for me by Digi Engineer…

Anybody knows how to write in modems with command line?

Hello Vinicius,

I’ve tried your command and it worked. Could you be more explicit on what are you trying to do? Maybe your .pro file is assuming a different firmware version than the one the module has flashed. In my experiment I was only changing AT parameters.

You can find mode information on this topic in this page.

Best regards,

i am using this page for my process, but i need to write AT commands and a KEY - AES encryption key. When i execute this command line an window of X-CTU open and close quickly and dont show me any information. The LEDs of the board should twinkle show the comunication with COM port but dont. I read parameters with X-CTU after execute the command line but i dont saw any difference between a modem with defaults value and modem with my parameters.

Hi Vinicius,

Please, be more specific on what you want to do. I tried it with an X-Stick running XB24-ZB - ZigBee Coordinator AT - version 20A7 firmware with all set to default. The .pro file I was trying to upload was generated with the XB24-ZB - ZigBee Coordinator API - version 21A7 with all set to default.

You are rigth, some times, it does not show the progress bar. However, today I was using a serial port sniffer and I realised that it was sending the firmware through it despite there was nothing showing in the screen and it seemed like the application had exit. I let it finish and the firmware and settings were rigth.

Then I tried with /I (interactive) mode and this way it did showed the progress bar, but I had to click on “Write” button.

The exact call:

X-CTU.exe /PCOM3 /BS9600 /Y / /I
X-CTU.exe /PCOM3 /BS9600 /Y /

Hope it helps, best regards.

P/S: I did some more tests and it seems that the application is running in background and not showing output (I’ve never seen the “completion codes” that are mentioned in the page). However, I can see in task manager that X-CTU is running.

P/S2: The serial port monitor I used… here

thanks! its work!

You’re welcom Vinicius, I’m glad it helped.

Did you get the “completion codes” or see the progress bar?

i can see the progress bar, but the most important is now the LEDs toggle!