Range test and maximum packet sending S1/S2

Range test and maximum packet sending

I configured two zigbee modules. Coordinator AT and router/end device.

The range test in X-ctu is 8-12%, the most of packet are lost, the xbees lie maximum 1m side by side with integral antenna.
If I use in terminal “send Package” (for example 200bytes) the router got only ~116 bytes and connection is lost(the other way the same), than I need send package again to get another package. I have always use default configuration and sometimes change parameters to check what is wrong with transmision, but can’t find bug.

A few mounth ago I could send 3000bytes per one send without connection lost with default configuration, now i can’t.

could you help me?

Have you done link budget calculation? Seems like obstacles in between two modules or facing high EM interference.

Could there be coorosion on the antenna or XBee pins? Is there serious air-born noise/surge energy (arc welders? induction furnaces) which may have damaged the radio receive circuits?

The other possibility is that Zigbee does NOT change channels even if noise becomes crippling - for example someone decided to use a 2.4Ghz audio-headset and it is totally saturating the SAME frequencies as your ZIgbee, which means you Zigbee rarely can transmit a sucessful packet.

You may have to manually move your nodes. So look at the channel in use (might be 0x0D or 0x0E), and at the SC setting in the coordinator (might be 0x1FFE).

You should force the coordinator to NOT use the old channel - so if it was 0x0D, then make sure bit 0x0004 is clear in the SC of the coordinator. You could just try setting SC=0x1F00, then power cycling it. This would prevent it from using channels 0x0B to 0x12. You’d also need to do a network reset on your other node. If it is a router, set JV=1 and then a power cycle would force it to seek the coordinator on other channels.

Look at this page:

Thanks for reply

I checked the antenna. I changed the firmware to 1020 for coordinator and 1220 for router and took it to free area, without any wifi noise than change SC=0x1F00 and got CH=16 (No Conflict). te test range with this “0123456789:;<=>?@ABCDEFGHIJKLMNO” it’s better now, in first 10 sec I get 35-40% and next 60 sec I got 20-25%… 3/4 packets are lost :confused:

You need to have your budget calculations for it seems useful for medical monitoring, and industrial sensor networks.