RealPort driver connectivity problems

I need some help with RealPort driver and DigiConnect device.
I have DigiConnect Me module connected to a serial port device. This works fine. Module is accessible via telnet and from web admin.

I installed RealPort driver on another linux host and now I try to configure this driver to comunicate through RealPort with that serial device.
I can use dgrp_cfg_node only because I have access to the terminal only.
I successfully (I hope) added my digi device in linux and started RealPort daemon. Next I run dpa.dgrp and here is the problem. RealPort driver doesn’t receive any data.
In dpa.dgrp device has status ‘Available’ but nothing happens.

Any help?

Have you configured the ME unit to use the RealPort profile on the serial port?

Are you able to connect to the port using dinc from the Linux host?

dinc 9600 /dev/ttyxyz

Press ~. from a newline to disconnect from dinc.

When I try to connect to the port using dinc I have:
/dev/ttyA100: Resource temporarily unavailable

Here is my Device Information from dpa.dgrp:
Device Description : Digi Connect ME
Unit IP Address :
Number of ports : 1
Server Port number : 771
Encrypted Sessions : default
Wan Speed : auto
Device ID : A1

Unit serial port configuration from web admin:
Port Description Profile Serial Configuration
Port 1 None Custom 9600 8N1

I will try to change serial port profile to RealPort first…

I changed port profile to RealPort and I’m still not able to connect to the port using dinc command:

dinc 9600 /dev/ttya100

/dev/ttya100: Resource temporarily unavailable

Depending on what settings were applied on the unit previously, you may need to kill any processes that had been running on the ME unit.

Telnet/SSH to the unit, login as root, and run the following command to check the port:


If anything besides RealPort is connected/showing, kill it:

kill #

Where # represents the ID from the who command results.