RedHat 9.0 Digi Neo modem echo using minicom


I have an 8 port Digi Neo card and I am using minicom to talk successfully to a modem. I can make it dial a phone number but I cannot get it to echo the results of AT commands from the modem.

I have tried the standard options of ATe1v1Q0 and I have local echo turned on so that I see my commands but I don’t see any OK responses or CONNECT etc.

I have also tried using “cu” to talk to the line but the same lack of echo results.

Any assistance would be most welcome.
Lindsay Gregory

I’m not sure what would be causing this behavior, certainly nothing on the serial port side would be able to filter out the modem results specifically. Best bet would be to call your modem manufacturer on that one.

My guess would be either a DIP switch setting on the modem or some init string in whatever application is using the modem.

Thanks for responding Michael

I checked with the modem suppliers but they say there are no dip switches on that modem at all. The modem will respond with OK to the ATE1V1Q0 command that I am sending so it must be the serial port settings that are losing it.

If I look the the stty -a settings on the line it says -echo but if I send stty sane to that line it resets echo but still “cu” will not echo an AT response.

Any other suggestions?

If you’ve already tried replacing the modem cable (possible bad RxD pin, etc.), next thing to do then would be to put a loopback connector on the port in place of the modem cable. Go into cu again and see if what you type echos back to you. If so, there’s no reason the port wouldn’t see what’s coming from the modem, unless the modem isn’t sending it.

You could also try connecting the modem to ttyS0 and check its behavior there compared to the Neo port.