ssh disconnects after small timeout on Digi CM

When I connect to console port via ssh (port menu or hi-range port number), digi breaks session afer small timeout. How can I set up ports timeout?

The configurable inactivity timeout value, if that’s what’s coming into play here, can be found under Serial > Configuration > Host Mode Parameters.

Another possibility is that its timing out client side rather than Digi CM side, so that’s worth looking into as well.

We are having exactly the same problem. All SSH connections time out after approximately 1 minute 40 seconds. Changing the TCP keepalive values does not help. Is there something else we are missing in the settings?

Are you talking about a Digi CM?

TCP Keepalive sounds more like a Portserver TS, in which case a seperate thread should be created.

Regarding the CM:

There are a couple of inactivity timeout settings.

One is for the ports as michaelt referred to earlier.

There also is one for the Port access menu itself located here:
Serial ports->Config->Port access menu conf->Inactivity timeout.

Note: The default timeout for both is 1min 40sec (100 sec).