Digi CM 16 - some ports get a read timeout

I have a custom software that communicates with several devices at once using their serial connection. For each device, the software opens a Raw TCP (Raw Telnet) connection, sends an initialization command, receives a response, and waits for the next command. When the software performs the step above in parallel with 3 devices it works perfectly.

The problem I have is when the software tries to perform the same action with 4 or more devices at once, any device after the third one with get a "timeout during read". The TCP socket timeout value is set to 3000 (3 seconds). I have to restart the connection on that device in order to work. I always get the same result. Anything after the third connection will fail.

Are there any issues with Digi Cm connecting all 16 ports at once? If I change the software app to delay 1000 (1 seconds) per connections, we connect to all devices without any issues. If I remove the delay, we only get the first three devices to connect.

We are running firmware 1.6.5. We tried to upgrade to 1.9.3 but that broke something else and we needed to revert back to 1.6.5.


I am still having this issue. We owned about 600 DigiCM 16/32-ports and they are deployed around many remote field offices. I need to find a solution to this problem before recommending researching other competitors.

The 1.6.5 firmware is 5 yrs old and there have been numerous fixes/enhancements since then. You do not state the problem with 1.9.3? But we would need you to test your app on 1.9.3 before we can further diagnose.

System assurance transmit/receive data on all ports simultaneously. This has shown that sustained baud rates of 19.2 and/or 38.4 can be sustained.

Also, what company are you with?

I am a contractor working for the Dept of Defense. The reason for downgrading from 1.9.3 back to 1.6.5 was due to some character escaped sequence been transferred incorrectly by the Digi. Some of the Raw TCP commands are escaped prior to send them to a receiver or a downconverter. We noticed the equipment stopped processing the commands with the new firmware. We replaced one of the devices with a simulator and found the received command was not the same as the original.
Is there something new in 1.9.3 that might be affecting escaped characters? Can it be disabled? Thanks.

Difficult to tell because you are so many revs back. Try turning off the port escape sequence and see if that helps:
–Serial ports->Config->Host mode conf->Enable/Disable port esc sequence=Disable

Preliminary tests disabling port esc sequence works. I need to perform more tests.
Now that I have 1.9.3 loaded, I continue to see the same problem reported previously when I was running 1.6.5. Do you think it is a weekness of the microprocessor not able to process that many request at once or is it the firmware?

Previously, we did not see the problem because all the devices were connected serially…one at a time. Our customer wanted us to change that model and start all devices at once.

We are also acquiring one of the new passport devices to see if we get the same behavior.

I met with Ben T. last week and he will like to be kept in the loop regarding this problem.