Transport WR21 Auto Run on Power Up

I can manually start a program made from the Digi ESP by running “python” in an SSH terminal. Everythin runs just fine.

But when I run 'cmd 0 autocmd “python” ', followed by “config 0 save”, the program never auto starts on power up.

Have also tried this via the web config console under Configuration->System->General->Command.

This seems to be an issue with multiple firmware versions I have tried 5212, 5223.

Nothing seems to work. Any suggestion?

Seems that the program would autoexec as expected, but the program would crash. I put a delay at the beginning of the program and all seems to work as expected.

This sounds like there are dependencies in my program (such as rci,sms,sarcli) that are not loaded on the device before the program starts. Is there a better way to handle this?

Would also be helpful to be able to catch everything coming out of the python command line once execution starts…

contact Digi Technical Support team for the python related questions.

Well Digi Tech Support says to setup a support agreement or ask here…

Not sure this helps

if you

import sys
sys.stdout = open (“”,“w”)

this sends all print statments out to a file