I am making use of the Frame log facility in new gen XCTU.
What is puzzling me is why sometimes I get a full TX/RX log, and other times, I get just the IO Data
RX Sample Indicator (frame type 92). The full log is large with unwanted TX frames and replies, when all I want is the 92 frame. Setting filters does not stop the unwanted data.
Sometimes, resetting the coordinator (API)stops the unwanted frames, but the only surefire method seems to be to close and restart XCTU.
Any ideas please? The XCTU Help does not have any information.

Can you provide screenshot or copy/paste unwanted logs that you are observing?

Hello killer32
Looks as though I can’t upload the screenshots here.
Quite simply, I can start one logging session without any changes to filters or whatever and just get the RECV frames - other sessions I get the RECV frames as well as all the SENT frames. The only way to stop this is to close and restart XCTU. No preferences other than the number of frames limit have been changed. If I could get the png files to you you could see exactly what is going on

Are you monitoring two com ports at the same time?

Hello mvut
A tricky one to answer. I generally have several COM ports on the go during these sessions. The coordinator XBee is always on COM4. To confirm that the XBee traffic is OK, I run a 433-MHz radio collecting pulses (this is all to do with energy meter monitoring and confidence building) on a separate COM port with an Arduino counting the pulses (the Arduino uses something like COM17 to look at it’s serial output), plus, I use another serial port with a Pico scope to record the 433-MHz traffic.
So the short answer is yes, I am using other COM ports, but XCTU has exclusive use of one port.
I must confess that I am very new to all this. All I do know so far, is that filtering the log file has no effect on the frames collected, only on what you can see on the screen.
It’s not a big deal, but just involves extra work in the spreadsheet. Nothing in the XBee configurations has changed. For what it’s worth, the “unwanted” frames are specifically “Explicit Addressing Command Frame” and “Transmit status”, plus “Modem status” for good measure.
At least I can fix it, but I don’t know why.

What are the address setting set to on your modules? Are they all set to the broadcast address? You should be setting them in this case case to the SL SH of who you want the data to come out the UART of. That is the only way to limit the traffic you are seeing.

Hello vmut
Thanks for your efforts
This is all early days for me and I only tinker with settings I understand, so any addressing will be the default setting.
This is a small network consisting of one C, one R (with no dig’s or analogues set), plus two R with a selection of A&D set. I will be taking a closer look at the finer details of addressing.
What I still don’t understand is why on one day, I just see the received frames on XCTU, then another, with nothing changed, I get the received and sent frames?
I expect it will fall into place one day.