u-boot doesn't show :Hit any key to stop auto boot

Hey guys
I already had made u-boot for my evaluation board and it was OK!
Now I want to port the same boot loader on my own custom board which has different structure.
Instead of 64 Mb SDRAM of standard board my board has a 128 Mb SDRAM and this board uses SDRAM bank 1 instead of bank 2 in standard board. Also my board uses a 12 MHz external oscillator instead of 8 MHz in evaluation board.

I change the settings but I see:

U-Boot 2010.03 (May 29 2017 - 10:12:45)

CPU : —
Freqs: SYSCLK=180MHz,HCLK=180MHz,PCLK1=45MHz,PCLK2=90MHz
Board: STM32F429II-SADR board,Rev 1.0
Using default environment

R0 = 90700000 R1 = 00000000
R2 = 00025800 R3 = 00000004
R12 = 000257fc LR = 08005a23
PC = 080007ea PSR = 21000000

and the below line doesn’t appear:

Hit any key to stop auto boot: 0

I changed delay time to 3 sec but the result was same and u-boot doesn’t start boot!!!
I would be thankful if you tell me what is the problem with my configuration.

looks like delay is disabled. are you building you own u-boot? Also it does not look like you are using a Digi product