Unable to use SoftAP on virtual wlan

Out of the box, the ConnectCore for i.MX6UL Starter Kit enables two wireless devices. The first device, wlan0, is configured for client access, while the second device, wlan1, is a virtual wlan configured as a SoftAP using hostapd and a pre-configured SSID. I am unable to connect to the SoftAP from an external device when it is hosted on the virtual wlan. I undertand that by default, there is no DHCP server ready to hand out IP addresses, but that is easily solved with dnsmasq or udhcp. The problem I am having is that the AP does not authenticate properly. It looks like the connection attempt times out while authenticating keys. I have tried changes to the hostapd configuration to no avail. I have also tried using wpa_supplicant in AP mode, but this fails to connect in the same way. I have read and followed advice on the Digi documentation pages including Access Point (https://www.digi.com/resources/documentation/digidocs/embedded/dey/2.4/cc6ul/yocto-bsp_r_wifi-access-pt) and Concurrent Modes (https://www.digi.com/resources/documentation/digidocs/embedded/dey/2.4/cc6ul/yocto-bsp_r_wifi-concurrent-modes). Nothing I did would allow me to successfully connect to the AP running on wlan1.

If I change the system so that the SoftAP is hosted on the real wlan, wlan0, then I am able to easily connect from external devices. wlan0 can successfully host the SoftAP using either hostapd or wpa_supplicant. This works even with the exact same configuration files for hostap / wpa_supplicant. Changing the device is the only thing needed. So, it is not an issue of a mismatched passphrase or psk.

I was hoping to be able to host the SoftAP on the virtual interface for the purpose of initial configuration / WiFi provisioning. Having the two wireless interfaces running concurrently provides the added benefit of being able to verify the client connection, while still connected to the device performing the provisioning steps. Can you please provide some advice for how to properly use the virtual wlan to host a SoftAP?

-John G.

What channel are you using for softAP? I believe default is on 5Ghz band. Try to move it to 2.4Ghz. Also, remember that real and virtual interfaces have to be on the same channel.

Thank you for your comments. I did not realize that the virtual and real interfaces had to use the same channel, but that makes sense. The real interface, wlan0, is managed by NetworkManager as a client STA and is not configured for a particular channel or connected to an AP. So, that does not appear to be the problem.

I did, however, have some success by moving the SoftAP to the 2.4GHz range. The default hostapd configuration for wlan1 includes the following:

IEEE 802.11ac


I changed this section to use 80211.g like so:

IEEE 802.11g


This allowed me to successfully connect to the SoftAP using an Android phone, an iPhone and a Windows 10 laptop. I am beginning to think this is an environmental issue and not a problem with the real vs virtual wireless interface. By changing the channel, I can re-create the problem I had where I was unable to connect. Once I find an open channel, it all seems to work well. This does give me some concern as we cannot predict all the RF environments where our product would be used. If the SoftAP connection is really sensitive to this, it may not work well for us.