USB to serial adpter reduces UART signal strength by half

We like to keep the WaveShare USB to serial adapter in our circuits for easy reconfiguration of the attached Xbees3. I am getting a TX signal via the 3.3 V Max 3483 Transceiver (RS485 to Serial).

If I monitor the plain signal, it has a strength of >3 V. If the TX line touches the WaveShare board, the TX signal drops to 1.5 V, which will not be recognized by the XBee3. The drop occurs with or without Xbee connected.

I was able to confirm the problem being on the side of the WaveShare board by trying with a different USB to serial adapter. And it worked. Unfortunately, we have the WaveShare boards stockpiled…

Any suggestions? I’m quite newbie, so please forgive if I’ve overlooked something obvious.

Thank you.

So now I got an offline hint saying that the WaveShare board uses a CP2102 driver vs. ICStation (the other board) uses FTDI. And that the TX signal from the Max3483 Transceiver would be “competing” with the CP2102’s on the TX line. But then, what’s the board good for if I can’t even see my serial signal?

That sounds like it is more of an issue with the Wave Share 3rd party device. It may simply not have a high enough pull up resistor on the line to bring the voltage up to 3V.

That is something that you would need to ask WaveShare about and not Digi.

I am using pull up resistors. The TX line has 3.3 V. but the signal drops to around 1.5 only not near zero.

That would mean that you have too much pull up on the line.

Thanks for the suggestion. We tried with 56k pull ups instead of the 10k we had before. No difference. I guess if the internal pull ups are to low, there is nothing we can do against the effect?