VCI4 USB-to-CAN V2 got error code 10 while connecting to AnywhereUSB/2

the combination of VCI4 USB-to-CAN V2 and AnywhereUSB/2 were working good in Windows7, but after changing the OS to Windows 10 (re-installed), VCI4 USB-to-CAN V2 can’t start and give error code 10.

if VCI4 USB-to-CAN V2 is directly connected to my laptop, it’s ok and working good as below:

I also try to solved it according the instruction below, but fail.
AnywhereUSB Host Controller in Device Manager has a yellow warning icon with error code 10 | Digi International

What can I do to solve this issue, many thanks!


Could you provide a screenshot of Device Manager when you see the Code 10 (when using Windows 10)?

Hello Jmcbane,

Thanks very much for your nice reply, I try to provide as much details as I can, please find below screenshots:

Looking forward to your reply!

does anyone can help on this issue?
is it due to firmware issue?

My best suggestion is to search the web for how others have solved this ‘device cannot start … invalid parameter’ Code 10 issue, and consider reaching out to the support team for this VCI4 USB-to-CAN V2 USB device to see if they can help.

Note that this is a legacy AWUSB/2 device that’s no longer supported and no longer covered under warranty.

If necessary, you could buy a newer AWUSB 2 Plus device and see if that works (it’s compatible with Windows 10 and compatible with most USB devices).

dewa poker