AnywhereUSB/2 Code 10

Trying to connect remotely to a DSP via my AnywhereUSB/2 and a WiFi router. Connection seems successful, stable but I keep getting a Code 10 error on this USB device in the Device Manager. Literally every other USB device I’ve tested troubleshooting this issue has worked fine except this DSP.

Any idea what could be causing these Code 10 errors? I’ve tried everything I can think of - Reinstalled both the AWUSB and DSP drivers, power-cycled all devices, updated firmware and drivers on all devices, tried using different routers, tried tunneling mode, Windows firewall off, pinging AWUSB from wirelessly connected PC provides acceptable results (min 1 ms, max 4ms, average 2ms, 465 packets sent, 0% lost), tried different versions of Windows. I’m out of ideas

This DSP was confirmed to work with the AnywhereUSB and my PC by other users.

Could be something wrong with the device if you have tried other Anywhere USB’s and they work but this one doesn’t.

Yeah, I thought about that. If so, it would have to be REALLY specific because I’ve tried several other devices and they all work without issue. Devices I’ve tried are:

  • USB Mouse
  • USB Keyboard
  • Cell Phone
  • USB Mass Storage Device
  • MIDI Controller (GUI config utility connects through USB)
  • USB 1.11 Sound Card (successfully connected. Don’t know if it actually worked in terms of passing audio, but a successful connection is more than I can get out of my DSP)

I’ve contacted the manufacturer of the DSP to talk about their driver. They’re taking their sweet time getting back to me though.

Have you tried the “Use Microsoft Device IDs” option? It’s in the Preferences section of the AWUSB Config Util. After you turn it on then click Update, disconnect from the AW and re-connect. Does that help?