AnywhereUSB/2 Won't Maintain Stable Connection

Using the AnywhereUSB/2 with a Netgear N300 Travel Router. Updated AnywhereUSB/2 with latest firmware. Using latest driver. The hub still won’t maintain a stable connection in the Remote Hub Config Utility. However, the Digi Device Discovery utility doesn’t seem to be having an issue, and I’m not getting the the USB reconnect/disconnect sound from Windows. I am getting an error code 19 from RealPortUSB 0 and 1 in the Device Manager, though.

Any ideas on how to correct this?

Surface Pro 3, Windows 10.


As I’ve been messing around with settings, the instability issue in the hub config utility seems to have self-corrected…somehow. I’ve moved on to troubleshooting why my USB device (audio DSP) is not showing a connection. Everything seems to be connected properly, AWUSB reports successful connection, but an error is registering for the DSP in the Device Manager (yellow triangle). The Device Manager reports error code 10: Device cannot start. I tried reinstalling the AWUSB and DSP drivers several times with no luck.

In my attempts to troubleshoot, I’ve also tried connecting another USB device through the same AWUSB + router setup, a programmable MIDI foot controller. The initial connection seemed successful and there were no registered errors in the Device Manager. When opened, the accompanying software for the foot controller also successfully registered the unit as connected through USB. However, the software consistently freezes as it tries to download data from the foot controller via AWUSB connection.

I think the conclusion is that there are still some connectivity issues going on here. The DSP driver must be more sensitive to them than the foot controller driver is, which I assume is why the DSP won’t even connect while the foot controller will yet eventually hangs partway through data transfer. By the way, the DSP is confirmed to work with the AWUSB system (my router, network settings, AWUSB settings, my individual AWUSB unit, and W10 are still wildcards though).

I’m just about at my wits end here. I’m not a networking expert by any means, and I think I’ve done just about all I can think to do. If anyone could offer some support, that would be great. Thank you!

Do you know if this DSP devices is “isochronous” regarding the USB transfer type specification it uses?