No connection to AnywhereUSB

I installed the 1.80 software on a physical machine and finally it works, I get a connection to the device and an USB stick shows up with its drive letter.

Then I installed the same software on a virtual machine (running on VMware ESX). Yes, I copied the usbd.sys driver before. I disconnected the AnywhereUSB on the physical node, and it shows the following on the status line: Total Discovered: 1, Connected To Me: 0, Available: 1, In Use: 0, Unconfigured: 0

I added the IP to the discovery list on the virtual node and the device shows up. BUT when I try to connect to it, it indefinitely says “Connecting to this computer…” and never finishes (the “Connected To Me” counter hops to 1 - whereas on the other machine the AnywhereUSB seems to be “Available for Host Connection”).

Rebooting of the virtual machine (W2K3) and/or the AnywhereUSB doesn’t help. WHAT’S THE PROBLEM???


  1. Double-check that “usbd.sys” is in “c:\windows\system32\drivers”. I’ve seen customers just put it in system32 before. I’ve also seen customers forget to rename it from “.sy_” to “.sys”.

  2. The 5 port LEDS on the front panel of the AnywhereUSB should be green, “roaming” left-right-left, indicating that the unit is available for a host connection. If the 5 port LEDs are solid green, this means the other computer is connected to the AnywhereUSB, so you’ll have to disconnect from the other computer first.

  3. What is your VMware network configuration for the W2K3 virtual machine? In other words, are you using “Bridged Networking”, “NAT”, or something else?

  4. What is the IP address, subnet mask, and gateway of the W2K3 virtual machine?

  5. What is the IP address, subnet mask, and gateway of the AnywhereUSB?

OK, here’s my update:

After installing SP1 and a lot of patches on the virtual server, AnywhereUSB still didn’t fire up the USB installation wizards. Then I copied some “missing” usb*.sys files from the physical W2K3 machine to the system32\drivers folder, but to no avail.

The solution:

During the “Connecting to this computer…” phase the “AnywhereUSB Remote Hub” device shows a yellow exclamation mark under Device Manager -> System devices. Right click -> “Update driver…” reloads the awusbsys.sys driver and JUST THEN the USB devices section shows up in Device Manager!

Then apply the same procedure to the 4 or 5 devices that appear one after another in the USB devices section and… bingo!

I then tried this on a second virtual W2K3 machine without SP1, patches and extra files - and it worked too.


Hello Johannes,

  1. Open Windows Device Manager and expand the Universal Serial Bus controllers section. Once the AnywhereUSB drivers are installed, you should have 2 AnywhereUSB Host Controllers and 2 AnywhereUSB Root Hubs (without yellow (!) or /!\ icons). What do you see in Device Manager on your W2K3 virtual machine?

  2. Click “Edit / Connection List” in the AnywhereUSB Configuration Utility and delete all entries. Afterwards, click the Connect button. If you are presented with found new hardware wizards afterwards, make sure to go through them (choose “No, not this time” if prompted to connect to Windows Update; choose "Install the software automatically " on the other window).

Please keep me updated here on the Support Forum.

On the problematic (virtual) machine there is no USB controllers section in Device Manager at all. The only evidence for an AnywhereUSB installation is under System Devices, there is a “Network Attached USB Enumerator” listed.

I compared both machines, the virtual W2K3 is without Service Pack 1. Could that be the problem?

I compared the \system32\drivers directories too, there are big differences (in file date/version due to the missing SP1), but also the working installation has a lot more usb* named files in there… (usbohci.sys for example)?!

I’ll install SP1 as a next step.


I am a similar boat as what is described here. Our virtual machine, Windows Server 2003 SP2 on ESX, has no Universal Serial Bus Controllers section, thus I cannot see any of the USB devices connected to the Anywhere USB device. The only device that shows up in Device Manager is the USB Enumerator. Please help!


Open the AnywhereUSB Configuration Utility and tell me the Status at the very bottom of the right-hand window.